Can't get this A400E fxo card to work on UK BT line

Hello All
Been trying to configure a A400E 1 fxo card . Having Read loads of info on the net about setting up this card, but still it does not work.

When I call the line from my mobile the mobile keeps ringing, but the extension on my system rings twice, hangs then rings twice and so on… If I answer the call the extention is dead, but the mobile keeps on a ringing. Put the extension down and it carries on with its two rings then hangs and so on…

Another strange thing is why is the pstn line phoning that particular extension, because I have not set it up to do so?

Just hope there is someone who knows this card and could point me in the right direction?

My system: Centos 6.5, Asterisk 13.7.0, Freepbx 12.0.76.2, Dahdi ver 2.10.0.1 echo canceler: oslec. The telephone line is a uk based BT analog line.
In the dahi config on the freepbx web gui the card shows up under analog hardware as expected:

Type - fxo ports 1 edit

/etc/dahdi/system.conf

fxsks=1
echocanceller=oslec,1
loadzone=uk
defaultzone=uk

/etc/asterisk/chan_dahdi.conf
[general]
; generated by module
#include chan_dahdi_general.conf
; for user additions not provided by module
#include chan_dahdi_general_custom.conf
[channels]
language=en
busydetect=yes
busycount=10
usecallerid=yes
callwaiting=no
usecallingpres=yes
threewaycalling=no
transfer=yes
cancallforward=yes
callreturn=no
echocancel=yes
echocancelwhenbridged=no
echotraining=no
immediate=no
faxdetect=no
rxgain=0.0
txgain=0.0
cidsignalling=v23
cidstart=polarity
; for user additions not provided by module
#include chan_dahdi_channels_custom.conf
; include dahdi groups defined by DAHDI module of FreePBX
#include chan_dahdi_groups.conf

/etc/asterisk/dahdi-channels.conf

; Span 1: WCTDM/4 “Wildcard TDM400P REV E/F Board 5” (MASTER)
;;; line="1 WCTDM/4/0 FXSKS (In use) (EC: OSLEC - INACTIVE)"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-pstn
channel => 1

/etc/asterisk/chan_dahdi_groups.conf
signalling=fxs_ks
context=from-analog
group=0
channel=>1

/etc/modprobe.d/dahdi.conf
options wctdm24xxp opermode=UK alawoverride=1 fxshonormode=0
options wctdm opermode=UK

If I run: lsdahdi I get

Span 1: WCTDM/4 “Wildcard TDM400P REV E/F Board 5” (MASTER)

1 FXO FXSKS (In use) (EC: OSLEC - INACTIVE) RED
2 unknown Reserved
3 unknown Reserved
4 unknown Reserved

If I run dmesg I get:

dahdi: Version: 2.10.0.1
dahdi: Telephony Interface Registered on major 196
WANPIPE™ Interface Support Module 7.0.12.2.0 © 1994-2013 Sangoma Technologies Inc
WANPIPE™ Multi-Protocol WAN Driver Module 7.0.12.2.0 © 1994-2013 Sangoma Technologies Inc
wanpipe: Probing for WANPIPE hardware.
wanpipe: No AFT/S514/S508 cards found, unloading modules!
usbcore: deregistering interface driver sdlausb
dahdi: Warning: Span WCTDM/4 didn’t specify a spantype. Please fix driver!
Freshmaker version: 71
Freshmaker passed register test
Module 0: Installed – AUTO FXO (UK mode)
Module 1: Not installed
Module 2: Not installed
Module 3: Not installed
Found a Wildcard TDM: Wildcard TDM400P REV E/F (1 modules)
dahdi_transcode: Loaded.
INFO-xpp: revision Unknown MAX_XPDS=64 (88)
INFO-xpp: FEATURE: with PROTOCOL_DEBUG
INFO-xpp: FEATURE: with sync_tick() from DAHDI
INFO-xpp_usb: revision Unknown
usbcore: registered new interface driver xpp_usb
dahdi_devices pci:0000:05:00.0: local span 1 is already assigned span 1
dahdi_echocan_oslec: Registered echo canceler 'OSLEC’
usbcore: deregistering interface driver xpp_usb
dahdi_transcode: Unloaded.
dahdi: disable_span: span 1
Freed a Wildcard
dahdi: Telephony Interface Unloaded
WANPIPE™ Hardware Support Module 7.0.12.2.0 © 1994-2013 Sangoma Technologies Inc
usbcore: registered new interface driver sdlausb
dahdi: Version: 2.10.0.1
dahdi: Telephony Interface Registered on major 196
WANPIPE™ Interface Support Module 7.0.12.2.0 © 1994-2013 Sangoma Technologies Inc
WANPIPE™ Multi-Protocol WAN Driver Module 7.0.12.2.0 © 1994-2013 Sangoma Technologies Inc
wanpipe: Probing for WANPIPE hardware.
wanpipe: No AFT/S514/S508 cards found, unloading modules!
usbcore: deregistering interface driver sdlausb
dahdi: Warning: Span WCTDM/4 didn’t specify a spantype. Please fix driver!
Freshmaker version: 71
Freshmaker passed register test
Module 0: Installed – AUTO FXO (UK mode)
Module 1: Not installed
Module 2: Not installed
Module 3: Not installed
Found a Wildcard TDM: Wildcard TDM400P REV E/F (1 modules)
dahdi_transcode: Loaded.
INFO-xpp: revision Unknown MAX_XPDS=64 (8
8)
INFO-xpp: FEATURE: with PROTOCOL_DEBUG
INFO-xpp: FEATURE: with sync_tick() from DAHDI
INFO-xpp_usb: revision Unknown
usbcore: registered new interface driver xpp_usb
dahdi_devices pci:0000:05:00.0: local span 1 is already assigned span 1
dahdi_echocan_oslec: Registered echo canceler ‘OSLEC’

and

dahdi_cfg -vvv
DAHDI Tools Version - 2.10.0.1

DAHDI Version: 2.10.0.1
Echo Canceller(s): OSLEC
Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Echo Canceler: oslec) (Slaves: 01)

1 channels to configure.

Setting echocan for channel 1 to oslec

Does anyone here know What does the Red Alarm signifies in the warning in the following CLI:

Executing [[email protected]:44] Dial(“DAHDI/1-1”, “SIP/210,Ttr”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/210
– SIP/210-00000008 is ringing
[2016-02-05 11:00:03] WARNING[3953][C-00000007]: chan_dahdi.c:7285 handle_alarms: Detected alarm on channel 1: Red Alarm
== Spawn extension (macro-dial-one, s, 44) exited non-zero on ‘DAHDI/1-1’ in macro ‘dial-one’
== Spawn extension (macro-exten-vm, s, 9) exited non-zero on ‘DAHDI/1-1’ in macro ‘exten-vm’
== Spawn extension (ext-local, 210, 2) exited non-zero on ‘DAHDI/1-1’
– Executing [[email protected]:1] Macro(“DAHDI/1-1”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“DAHDI/1-1”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“DAHDI/1-1”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘DAHDI/1-1’ in macro ‘hangupcall’
== Spawn extension (ext-local, h, 1) exited non-zero on ‘DAHDI/1-1’
– Hanging up on ‘DAHDI/1-1’
– Hungup ‘DAHDI/1-1’
[2016-02-05 11:00:05] NOTICE[2114]: sig_analog.c:2661 analog_publish_channel_alarm_clear: Alarm cleared on channel 1
[2016-02-05 11:00:06] WARNING[2114]: chan_dahdi.c:7285 handle_alarms: Detected alarm on channel 1: Red Alarm
== Starting post polarity CID detection on channel 1
– Starting simple switch on ‘DAHDI/1-1’
[2016-02-05 11:00:09] WARNING[3970][C-00000008]: chan_dahdi.c:7285 handle_alarms: Detected alarm on channel 1: Red Alarm
[2016-02-05 11:00:09] WARNING[3970][C-00000008]: sig_analog.c:2524 __analog_ss_thread: Hangup received waiting for ring. Exiting simple switch
– Hanging up on ‘DAHDI/1-1’
– Hungup ‘DAHDI/1-1’

I read it means the line is not connected, but that cant be so in this case because the call is coming in. The line works fine on a standard phone, so my only guess is that its down to misconfiguration. I’ve made some changes to : /etc/modprobe.d/dahdi.conf so it now reads:

options wctdm opermode=UK
install wctdm /sbin/modprobe --ignore-install wctdm && /usr/sbin/dahdi_cfg

Another thing that concerns me is when I run dmesg I get a line:

dahdi: Warning: Span WCTDM/4 didn’t specify a spantype. Please fix driver!

And from lspci -v this card is loading the wctdm driver:

Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface
Subsystem: OpenVox Communication Co. Ltd. Device 0001
Flags: bus master, medium devsel, latency 32, IRQ 19
I/O ports at d000 [size=256]
Memory at e9100000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [40] Power Management version 2
Kernel driver in use: wctdm
Kernel modules: wctdm, hisax, netjet

Someone, anyone PLEASE PLEASE HELP!!!

Sorted it now, all working. Thanks for the help.

I have similar issues. I am in the UK. My extensions ring twice (showing the CID number) then stop. They then start ringing again showing CID as “unknown”. I can’t take the call if I pick up in the two rings… the line goes dead and then when I put the extension down the phone starts ringing again (“unknown caller”). I can answer the call if I wait until the phone rings with “unknown caller” ID.

Is there any chance you could list the settings you changed, please ?

Thank you

Ian

caller ID from UK is quite unique, please refer this link:http://www.voip-info.org/wiki/view/Asterisk+and+UK+Caller+ID

Thank you James

When the phone rings I do get Caller ID (having previously made changes to the required config files).

What I am trying to solve is the issue where incoming calls ring twice. The 1st time with 2 rings (which I can’t answer) then stop followed by 2nd time which I can answer.

Thanks

Ian