Can't get Sangoma Phones Provisioned on PBXact


(David Gilbert) #1

(I realize this problem is probably due to my own error… so forgive me for my ignorance in advance.)

I’ve got a Sangoma PBXact 25 and three Sangoma phones (1x S505, 2x S305) that I cannot get set up correctly. I have followed the setup in the wiki (as well as a youtube tutorial) for autoprovisioning via PnP, via redirect service, and hard setting provisioning server into phone. I still can’t get any of these phones to provision. (I’m afraid somewhere along the way it may gloss over something that is very obvious to someone who knows what they’re doing, while I probably don’t even know enough to be dangerous.)

I have the phones set to static IP and have not tried the DCHP Option 66 because our business internet providor will not allow customers to access their modem or do anything technical in that regard, so I have no way to manage that other than spending days on the phone with them. I use the DCHP as little as possible due to an issue we had a while back after spending several days on the phone and for whatever reason they changed our subnet without telling us and the DCHP had major problems with everything we had connected, so now I try to put static IPs on as many devices as possiible.

So I’m pretty lost, and I’ll probably need someone to explain it to me like I’m 7. Actually maybe explain it to me like I’m 4. This seems all pretty plug and play with minimal setup, but apparently not.

I do have the endpoint manager global settings configured. I do have templates set up. I have extensions set up and the templates and mac addresses correct for each phone. I’ve tried to change the templates to provision via TFTP and HTTP.

Any help is appreciated. I’ll be happy for an easy solution even if it does make me look even dumber.


(Dave Burgess) #2

If this is a new “from Sangoma” installation, file a ticket for commercial support and someone should be able to point you in the right direction.

Not saying no one is going to help, but since it’s all Sangoma commercial equipment, you should be able to get warranty support assuming you bought the equipment recently.


(David Gilbert) #3

Good advice. I opened a ticket, but apparently got it solved before I heard back.

For reference (in case anyone else is as bumbling as I): I had set up the redirect on the sangoma portal (not the first method I had tried) for tftp, but I didn’t realize that a factory reset was required instead of a reboot, which made the phones retrieve the correct configs.

That pushes the IPs to DHCP which I don’t know will cause problems down the line. Also don’t know if I can change the IP to static afterwards and they still work correctly, but I’ll play around with it a little more and worst case it’s working now.


(Itzik) #4

Use http instead of tftp