Can't get FreePBX to change encryption settings in DB

Have one extension enabled which for some unknown reason won’t loose any encryption settings. Any extension in the office can call the problematic ext number, but it doesn’t work the other way around: chan_sip.c:10525 process_sdp: Failed to receive SDP offer/answer with required SRTP crypto attributes for audio

Tried setting: Enable Encryption = yes and subsequently tried Enable Encryption = no

It did not change anything. Did same with Media Encryption using both types. Same results.

After changing everything back to ‘no’ any outbound calls attempted from the problematic extension cannot be made.

Created a new extension. Changed the user settings in the polycom vvx300 phone and it worked perfectly. Changed the user/pass settings in the phone back to the original extension and same… cannot make any calls.

When making change to the ext in the GUI…
chan_sip.c:30535 build_peer: ‘tls’ is not a valid transport type when tlsenable=no. If no other is specified, the defaults from general will be used.