Can't get call transfer to work


I am having a very strange behavior to execute call transfers
blind and attended.

I added “tT” in dialog options in General settings

I try to transfer a call initiated with BOL SIPPhone.

When I use the dedicated transfer button, it works fine.

When I press “##” most of the time it has no effect,
if I press many “#####” some rare time I hear “transfer”.

In file “features.conf” I replace “##” with “#” and this
way it works much better and I can blind transfer calls.

But I am afraid one “#” will interfere with other IVR
encoutered, therefore I would rather use the default
double #.

I also tried to enable “*2” in file “features.conf” to
use attended transfer calls. When I press “*2” it has
no effect. I also tried to change to “#2”, same result,
I mean no effect.

Any help would be very appreciated.

Phil Ten

I just found that the cause seem to be a timeout issue.
Default values seem to be too short in my case.

Adding the following lines in file features.conf seem to solve
the problem.

transferdigittimeout =>3 ; Number of seconds to wait between digits
; when transferring a call (in seconds)
featuredigittimeout = 2000 ;Max time (ms) between digits for
; feature activation. Default is 500

Phil Ten