Can't get Amazon Chime to work with FreePBX

So then see whether the INVITE shows up in tcpdump on the PBX. If not, it could be dropped by your modem (if configured as gateway) or your router/firewall. If the latter has a SIP ALG or “SIP passthrough” function, try turning that off. If you still have trouble, post make and model of both devices.

I managed to run tcpdump and tried an inbound call, but when I try to pull the log files from tcpdump using WinSCP it keeps saying, “Timeout detected. (control connection) Connection failed.” My settings for WinSCP are as follows, File Protocol = FTP (Yes I did try SCP), Encryption = No Encryption, Hostname = 45.47.13.117 (That is the IP Address to the FreePBX server), Port Number = 5060, User Name = root, Password = (the root user password for the FreePBX server). I have went into FreePBX and made sure that my computer IP Address, which is the one trying to access the files, was not getting rejected by FreePBX. Is there maybe a wrong setting? Or should I use a different application for pulling files off the FreePBX server?

How did you choose this non-standard value?

I just typed in 5060 in the port option. If that is not the answer you’re looking for I ran the log file to use port 5060.

Assuming that your Windows PC is on the same LAN as the PBX, if you want to use WinSCP for this, try:
File Protocol: SFTP
Host Name: 192.168.1.20
Port Number: 22
User Name: root
Password: (the root password for your FreePBX)

Or, use psftp (included with PuTTY)

I have the log file now but it is encrypted. Any idea of how to unencrypt it?

AFAIK, tcpdump does not encrypt capture files and has no option to do so. A pcap file is a binary format that you can open in Wireshark and certain other tools. What command did you use to make it? How big is it? How did you try to read it?

I have decoded the binary format using Wireshark:https://pastebin.com/cZH5KNKS and https://pastebin.com/470sr9yJ

Just in case you need it, I used the command: tcpdump -i eth0 -s0 -w/tmp/pcap.pcap port 5060 then I stopped the capture using CTRL + C, the file size is 1KB, and I tried to read it using NotePad.

So the trunk on FreePBX is set up for UDP but the inbound route on Chime is set up for TCP. No worky.

Assuming that you want UDP, change the setting on Chime.

Since Amazon can send calls from various addresses in 3.80.16.x, set Match (Permit) for the trunk to 3.80.16.0/24 and (if running FreePBX Firewall) set 3.80.16.0/24 as Trusted.

Then retest incoming.

I have done everything you said to do, now when you call it, it will infinitely ring but never reach my IP Phone. I have checked that my inbound routes are set to my extension, made sure that there is nothing wrong with my extension, and made sure that the IP Phone was properly connected to FreePBX. But still doesn’t reach my IP Phone.

Can you successfullly call the IP phone from another extension? If so, paste the Asterisk log for an incoming call attempt (including pjsip logger) and post the link.

If not, paste the log for a call between the extensions.

If you don’t have another IP phone, set up a softphone, such as MicroSIP, PhonerLite, etc.

So now both work, I went to go add another extension, and instead of using a softphone, I just added another extension to a free line open on my phone. Then I went to add the extension to the inbound list, and I called the number and it worked. But if I get rid of the second extension and go to the inbound settings to make it go to the only extension, when I call it doesn’t work. Pretty weird. Anyways, I’m happy it works now, and thank you for helping me through this process. I probably couldn’t have done this without you because there is nobody out there with my specific problem. I hope you have a great rest of your day.

Actually, there is another problem, it’s off-topic of Amazon Chime trying to work with FreePBX but I set up an IVR and if you click 1 it will bring you to the 1001 extension but if you click 2 it will bring you to my second extension 1002, you can get to the IVR, but if you choose an option it will infinitely ring but my phone doesn’t ring at all. I can call between extensions and the other extension will ring but inbound calls won’t ring the phone.

Paste a log including pjsip logger.

here is the full log with PJSIP Logging enabled when I call the number: https://pastebin.com/xFuVkyxB

Sorry, I don’t know what is wrong, other than at line 492, it appears that calling ext. 1001 is successfully initiated, but the INVITE never gets sent.

A couple of guesses:

  1. It’s hung up trying to do some kind of STUN/TURN/ICE lookup. If in Asterisk SIP Settings → General you have anything in Media Transport Settings or ICE Host Candidates, try removing it.

  2. The extension appears to be connected via Microsoft Internet Connection Sharing, which may somehow be causing the trouble. Can you connect the phone to a free port on the router or a switch, so it gets a 192.168.1.x address?

  3. Earlier in the thread you noted errors related to tel: URI. They seem to still be happening for ext. 1001, but not 1002. Can a call via the IVR ring 1002? If not, please try with an extension other than the Cisco phone.

How it is possible because this version of asterisk is very stable version…

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.