Can't get Aastra phones to take config

I am not sure what I am doing wrong. I have Aastra 57’s and 6749i’s. I made templates, saved them, mappped them to the phones, saved that, rebuilt configs.

I have tftp running. It is saving the files mac.cfg files in /tftpboot.

I have the config server on the phones set to the IP of my freepbx server. I have tried blank and / for path. I can change firmware from the tftp server. I have also tried setting the phones back to factory settings.

Things of interest:

There is no Aastra.cfg Should there be?

I removed Aastra xml scripts after I installed Endpoint manager.

Where should I go from here?

Thanks

Turn up verbosity in tftp server by adding -vvv to the end of server_args line in /etc/xinetd.d/tftp

Restart the service ‘service xinetd restart’

Tail the /var/log/messages file while you reboot a phone and see what the issue is.

Thanks!
I did exactly as you said and found out that it was looking for aastra.cfg and stops there. I had renamed aastra.cfg because it was wrote by the xml scripts. I made a new aastra.cfg file and it loaded up the aastra.cfg and mac.cfg first try.