FreePBX | Register | Issues | Wiki | Portal | Support

"Can't find page zones" when I try to resolve "Trusted Interface Detected"

firewall
configuration
Tags: #<Tag:0x00007fb907d9cf98> #<Tag:0x00007fb907d9cd40>

(Zachary Gallagher) #1

It’s this link.

http://freepbx/admin/config.php?display=firewall&page=zones&tab=intsettings

I installed FreePBX, it was good. I did the first updates of modules. And it broke. That’s… about it.

My current version of FreePBX is 13.0.190.19, and the “System Firewall” module is 13.0.44.4

I don’t know of a way to see every module that was changed in the first update, so I can’t list what changed.


(Zachary Gallagher) #2

It looks like this: i.imgur.com/WdxChre.png


(Fraser) #3

I have the same problem


(Rob Thomas) #4

That’s a bug. Just fix it in the firewall module itself.


(Matthew B) #5

I get this message “Trusted Interface Detected” on the Dashboard. I click the Resolve link, and of course, I get the error “Can’t find page zones”

Rob, you said to go to the Firewall page itself and fix it. OK, I understand that. But when I go to the Firewall page, I see my eth0 as "Internet (Default Firewall). Isnt that correct? If so, why am I getting the “Trusted Interface Detected” on the Dashboard?

Thanks.


(James) #6

I have the same issue. I have had it ever since the new firewall was implemented. Since both interfaces are on the internal firewall protected network I have not worried about it.

I thought today I might try to resolve it and it doesn’t seem to matter how I change it I get that same error on the dashboard. Actually got another when I tried to enter the trusted network ranges. It also thinks my client is on a 10.10.10.x/32 network which I don’t think is even possible.


(Andrew Nagy) #7

What version of firewall


(Matthew B) #8

Firewall: 13.0.44.4 on FreePBX 10.13.66-19


(James) #9

Mine is the same.

I jacked with the settings some more and by setting the Networks IP ranges to Local(Local trusted traffic) the dashboard now shows all ok.


(Matthew B) #10

That did not work for me unfortunately.


(James) #11

Well, it gets rid of the messages but leaves the ucp blocked for users on the local networks. Even that is spotty, seems to only fail when using the FQDN and works with the IP… When I changed those networks back to Trusted(excluded from firewall) so that they seem work for users then the message comes back. I tried a lot of things.

Is 10.10.10.0/24 a valid definition for a network in these settings? or should I use 10.10.10.*/24?


(Matthew B) #12

10.10.10.0/24 seems valid to me. I don’t know if you can use wildcards, I would guess not.


(Rusty Ballard) #13

Can You explain how to fix this in the firewall module? I have changed the eth0 and eth1 to " Internet (Default Firewall) and I still have “New Interface Detected” in the dashboard and when I click on “Resolve” I get " Exception Can’t find page zones". Where can I go from here?


(Lorne Gaetz) #14

Browse to Connectivity, Firewall, Interfaces. It may be that you’ve already resolved it, in which case you can just dismiss the notice.


(Dave Burgess) #15

The URL in the notice is still sending people to the wrong page.

Resolving the issue is the important part. Getting an undefined URL is mostly just disconcerting.


(David Thomas) #16

I am having the same error and it doesn’t look like anyone here has come up with a fix yet. I have tried a number of things but nothing seems to work. Getting desperate now. I tried to file this as a “Bug” but they said it wasn’t and closed my ticket.


(Andrew Nagy) #17

No. That is not what we said. We have closed your three issues with the exact same message.

https://issues.freepbx.org/browse/FREEPBX-14765 is still waiting for someone to provide feedback.


(Lorne Gaetz) #18

The link that is not working for you just takes you to the interfaces page to fix the issue. As already stated here, you need only browse to Connectivity, Firewall, Interfaces to get to this page.


(Matthew B) #19

I just added repro steps for my box.


(Manuel Tejada Guzmán) #20

I have the solution.
Only ejecute “fwconsole ma --edge upgrade firewall” to upgrade the firewall, then I reboot my server and finally, on browser, apply config on your PBX web.

I found it in other post, but I’m a new user and I can’t post any URL.

Sorry for my bad english.