Can't dial 100x extenions after picking up the phone but can before?

This is a question about an old trixbox, planning on moving to FreePBX soon. But in the meantime I am trying to move us from 3 digit extensions to 4 digit, specifically 100x. For some reason if I pickup the handset and start to dial say 1001, it does 10 but then says my call can’t be completed as dialed, it does 10(10).

However, if I just dial 1008 and then pickup the handset it will start ringing and works fine. Does anyone know why this is happening and how to fix?

Yes, the dial plan in the phone is incorrect.

In the future state the phone type when asking for help.

We are using mostly Polycom 335, but there are some 321, 550, 650 and Cisco 6940Gs. This particular issue is only occurring with the 335 at the moment but I need to make sure it does not happen with the others also.

Here is the current dial plan we have in place, doing some research to try and figure it out at the moment.


I am talking about the Polycom dial plan, this is not a FreePBX/Asterisk issue. The phone has a dial plan that processes rules prior to forwarding digits in the SIP invite to Asterisk.

This is the digitmap when I log into the phone, is this where the issue is? If so do you know how I would fix this in the endpoint manager or if not the right place where I should look?


I found this

They are saying you can’t use 1000 extensions? They say to see the wiki page but it is dead.

I tried the following on my phone per


This did fix my problem.

On a global level though I don’t know how to update it, I’m hoping there is something in endpoint manager but I dunno. I tried changing this but it didn’t seem to apply to the phone I rebooted.


You should be able to modify the template in the endpoint manager.

I am glad you see how the DP works. It makes the phone much more user friendly to have a well crafted dial plan.

Nothing wrong with 1xxx extensions, you should have 1xxx in the dial plan. Should also have *1xxx and **1xxx to enable xfer to vm and directed call pickup.

Any idea why the change I made to the reg_mac.cfg dialplan didn’t take? Is there somewhere else I should be making the change?

I am sorry not familiar with the endpoint manager in FreePBX.

I have pointed my endpoint guy to this thread in case he may have time to answer your question.

Sweet thanks!