Cant delete voicemails and dont receive emails about them (sendmail)

Hi, I’m new to Asterisk and FreePBX, I just switched our old PBX to this combination and I’m really happy about it (:
The only 2 problems I have are:

A. Agents cannot delete old voice messages (“your message was been deleted” but next time you call to the voicemail, it still counts “1 new voicemail”).

B. Even when I choose to send email attachment for voicemails, nobody get anything. I dont have any clue how to even start checking the problem, I dont know if the pbx server run a mail server or which one I need… Its a Debian Linux and I can see the emails under spool/asterisk, but it stuck there…

Any tip will be great!
Thank You.

Asterisk 1.8.3 on CentOS

I have same problem of a stuck message in inbox. How it came to be there will probably remain a mystery as my parents have been here and will have pressed every illogical sequence of buttons possible.

If try to delete from phone reports 1 new and 3 old messages. When I press 1 for new messages says “first” then goes straight to options to delete etc. (note not “first new message” and no message envelope). Trying to delete says message deleted but still there but am able to change to and delete old messages

If try from web interface, messages (1 new 2 old now) show up on folders list, opening initially on inbox showing message in inbox complete with message time date and Caller ID. Any attempt to delete this message or change to view old messages reverts to login screen with messge still there when I log back on. (I don’t regularly use web interface so this could be me doing something wrong)

TTY to inbox shows the 3 files for msg0001 (presume I can resolve problem by deleting these)

Log files show following

[May 13 10:13:32] NOTICE[28210] app_voicemail.c: Mailbox: /var/spool/asterisk/voicemail/default/220/INBOX, expected 0 but found 1 message(s) in box with max threshold of 100.
[May 13 10:13:32] NOTICE[28210] app_voicemail.c: Mailbox: /var/spool/asterisk/voicemail/default/220/INBOX, expected 0 but found 1 message(s) in box with max threshold of 100.
[May 13 10:13:32] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-youhave.ulaw’ (language ‘en’)
[May 13 10:13:33] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘digits/1.ulaw’ (language ‘en’)
[May 13 10:13:33] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-INBOX.ulaw’ (language ‘en’)
[May 13 10:13:34] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-and.ulaw’ (language ‘en’)
[May 13 10:13:35] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘digits/3.ulaw’ (language ‘en’)
[May 13 10:13:35] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-Old.ulaw’ (language ‘en’)
[May 13 10:13:36] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-messages.ulaw’ (language ‘en’)
[May 13 10:13:37] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-onefor.ulaw’ (language ‘en’)
[May 13 10:13:38] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-INBOX.ulaw’ (language ‘en’)
[May 13 10:13:39] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-messages.ulaw’ (language ‘en’)
[May 13 10:13:40] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-opts.ulaw’ (language ‘en’)
[May 13 10:13:46] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-helpexit.ulaw’ (language ‘en’)
[May 13 10:13:50] VERBOSE[28210] file.c: – <SIP/431-00000eb6> Playing ‘vm-first.ulaw’ (language ‘en’)
[May 13 10:13:51] WARNING[28210] app_voicemail.c: No message attribute file?!! (/var/spool/asterisk/voicemail/default/220/INBOX/msg0000.txt)

Note it appears to be looking for msg0000 rather than msg0001 as present in folder so I presume this is where the problem lies.

I’m a bit pressed for time at the moment to trace back further but have left files in inbox for now if further investigation is required

Asterisk version is

So I guess an update is in order!

anyone have any clue what is that problem?

thanks !

Can the messages be accessed/deleted using the webinterface?

Could there be permission problems somewhere?

I have installed the systems I run from an ISO, where everything just works (mostly), so I’m no expert…

Best regards,

Mikkel C. Simonsen

from which menu can i reach the voicemails in the webinterface? thank you!

Recordings in the top navigation, or the /recordings/ URL.

Best regards,

Mikkel C. Simonsen

i tried to delete the folder completely (/var/spool/asterisk/voicemail/default/123 but the agent still had his messages (one new and one old) so they are not stored there for some reason.

he deleted the old one from the system (*97) but the new one could not be deleted or played.
when he press 1 “for new messages” the system does not play the message and just read him the options after that.
pressing 7 says “deleted” but if you call again to *97 you still have 1 new message.

its the same thing on all of our extensions if they had a voicemails and removed them (the extensions that didnt had voicemails still empty).

Try deleting at /var/spool/asterisk/voicemail/default/extension#

Obviously you don’t want to do this for every phone but you can try it out on a couple. This will remove the VM but you don’t want to do this for each phone; however, you can then call the extension leave a message and make sure it can be deleted from the voicemail system when you call it back.

1 Like

thank you, i’ll try that.

any suggestions about the email feature?

You need to update asterisk. This was a known bug in 1.8.3 where the voicemail count would be offset by one.

Unfortunately, I’m using not 1.8.3, and I have two extensions with the same problem, cannot delete the problem voicemail from either of them.

When we select voicemail, and log in, the prompt says “first” then goes straight to information on how to delete, next voicemail etc…


Unfortunately there is no Asterisk version 2.7.0. You are extremely confused as I am talking about Asterisk 1.8.3 of which 1.8.x is the HIGHEST version

Fyrebaugh - youre talking about freepbx version.
to see the asterisk version, place your mouse pointer on the name “asterisk” in the main page of freepbx (on the green status line).

Some time when you try to delete voice messages from your phone by pressing 7 and 6 continuously, messages still show up after you disconnect and reconnect to voice mail. In order to get rid of the voice messages in this situation, Log in to Asterisk and click on the extension for which you want to delete the messages and uncheck the box where it says “ Enable voice mail for this user” , and click on update button. After you do that go to the actual phone and delete all the messages and come back to asterisk and check the box for “ Enable voice mail for this user” which you unchecked earlier and click on the update button.


I have the same problem. sometimes users can’t delete voicemail and whe have to do that manually.My asterisk version is under Debian.
Can someone tel me in which version this bug is fixed please?


Can I find the fix in the asterisk’s changelog?