Can't create new dynamic route


I’m using FreePBX and have been, with a pretty static configuration except for some changes in extensions, for a while and through several upgrades.

A few years ago I learned about dynamic routes and created one that compared CID to a database of my contacts and routed the call accordingly. It worked well and continues to.

I wanted to make another dynamic route and found that I was unable to. The dialog comes up, lets me enter all the necessary things in the necessary fields, lets me click “Save” without complaint, but after I apply changes the new route isn’t there.

In case it’s because of an error in my entry, I’ve tried entering the exact same route (with one meaningless change to make it different) and it behaves the same.

No errors show on the page. I don’t find anything in the logs when looking for my dynamic route’s name. I’d try deleting and re-creating my good dynamic route but I’m afraid I wouldn’t be able to re-create it. And I’d try just manually creating a file but I can’t find where the dynamic routes are stored.

Any suggestions would be greatly appreciated. Thanks.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.