FreePBX | Register | Issues | Wiki | Portal | Support

Cant connect to online mirrors php7

freepbx
Tags: #<Tag:0x00007fb9047b3bc0>

#1

Hi,

I installed freepbx 14 on my debian 8 machine and GUI shows warnings like ‘modules … signed by invalid key’. When i try to upgrade modules it shows ‘Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org).’

i saw from one discussion to try this command:

# /var/lib/asterisk/bin/freepbx_setting MODULEADMIN_SKIP_CACHE 1 && amportal a ma upgrade framework && /var/lib/asterisk/bin/freepbx_setting MODULEADMIN_SKIP_CACHE 0
trying to run as user asterisk:

MODULEADMIN_SKIP_CACHE] already set to [1]


Please wait...

!!!!amportal is depreciated. Please use fwconsole!!!!
forwarding all commands to 'fwconsole'
PHP Warning:  Declaration of FreePBX\Console\Application\FWHelpCommand::setCommand($command) should be compatible with Symfony\Component\Console\Command\HelpCommand::setCommand(Symfony\Component\Console\Command\Command $command) in /var/www/html/admin/libraries/FWHelper.class.php on line 15
No repos specified, using: [standard] from last GUI settings

Downloading module 'framework'
PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; xml2Array has a deprecated constructor in /var/www/html/admin/libraries/xml2Array.class.php on line 24
The following error(s) occured:
 - Retrieved Module XML Was Empty
...

then tried following command:

2#  amportal a ma refreshsignatures

Please wait...

!!!!amportal is depreciated. Please use fwconsole!!!!
forwarding all commands to 'fwconsole'
PHP Warning:  Declaration of FreePBX\Console\Application\FWHelpCommand::setCommand($command) should be compatible with Symfony\Component\Console\Command\HelpCommand::setCommand(Symfony\Component\Console\Command\Command $command) in /var/www/html/admin/libraries/FWHelper.class.php on line 15
Getting Data from Online Server...
PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; xml2Array has a deprecated constructor in /var/www/html/admin/libraries/xml2Array.class.php on line 24
..

Kindly help here!

Regards/


(Andrew Nagy) #2

We do not support php 7 at this time.


#3

Oh ok…
Kindly reply with any best possible suggestions to make this work!

Regards/


(Tony Lewis) #4

Downgrade to PHP 5.3 for FreePBX 13 and PHP 5.6 for FreePBX 14


#5

Well I initially tried to install php5 only but it returned error which was the reason I went for php7 instead. My Linux kernel is 4.9.15

Regards/


(TheJames) #6

Linux kernel version does not matter. you need to get the proper version of PHP. You may have to compile if you cannot find packages for your system.