Can't change HTTPS cert and Hostname

At first I only wanted to replace the lets encrypt cert with one we bought. I uploaded it and set it as default.
Then I went into the “Admin” -> “System Admin” -> “HTTPS Setup” setting and chose the new cert and clicked “Install” then the Button gets grayed out saying “Installing…” and the “Apache Config” line is blank shortly then it says “Apache Config: Apache Configured” but nothing changed. The cert is still the old one.

I searched for all the files (ssl.conf etc.) and they were still the same, so none were auto-generated for the new cert. Reboot does nothing.

Then I wanted to change the hostname first so I went to “Admin” -> “System Admin” -> “Hostname” and tried to change the hostname but it’s the same there: The line gets grayed out and turns normal again and nothing changes.

This is the FreePBX virtual appliance.
Current PBX Version:
Current System Version: 12.7.6-1904-1.sng7

There are no logs or error messages. This is also not a system I have set up. I recently joined the company and all other admins don’t have an idea either. Please understand if I can’t provide all information needed at once. Any suggestions?

Possibly your sysadmin rpm is out of date? Recent update to sysadmin rpm

1 Like

I did a “yum install” and everything works now. Thank you so much!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.