Can't call external cell phones

This will be a little vague unfortunately, and I’m sorry for that. We only have one phone server to test on, and it’s in production right now so I’m somewhat limited. I have a VM with it loaded, so I can look for things at least. Skip to bottom if you don’t want backstory.

We installed FreePBX distro last week on a testing machine. (FreePBX I think) We then took the test machine’s hard drive and put it in the production server. After configuring the network, it was up and running fine.

One reason for the switch from Trixbox (other than the obvious dead-ness) was that we recently had a problem with one user’s Blackberry not able to confirm calls by pressing 1. He would press it a lot and nothing happened and it just moved on to the next guy in the ring group.

When someone calls in, it goes to all the phones so someone here can answer the call. After internal calls, it rolls over to a ring group with Zach’s cell phone number in it 1xxx666xx16#, then the next ring group called Pause which does nothing and has the number of 0, then the next ring group (55) of Tom’s cell phone: 1xxx555xx44# (the x’s are numbers in real life)then it goes to a ring group that has the internal “voicemail” number in it (199). Here, it leaves a voicemail and then emails us the wav file.

Zach hasn’t been able to answer the call by pressing 1, but Tom can.

So back to the install… We got it all going and it worked great, but again, Zach can’t confirm calls. Switched ONLY Zac’s number to Mark’s number (different guy) and now it works. So it must be Zac’s blackberry that has issues. Well, we switch it back, don’t change anything else (intentionally). Call in now, and it says “please wait while we transfer you” just like normal, but never rings either cell phone and basically goes straight to voicemail (199) from (53). If we dial JUST the ring group (55) from our internal phone, it goes to the phone just fine.

So in summary, something’s killing it when going from ring group (53)(internal) to ring group (54)and (55) (external-cell phones). What are some settings to look for on this? I can look into settings, I just can’t test much until this weekend.

OK, so I added that extension for the number/blackberry that wouldn’t confirm the call.

When calling ext. (9001) from my phone at work, it goes to BB and I can confirm. Yay!

When calling ring group 603 which just has that BB number in it in the “extension list” 15552225522# , it does not let me confirm.

When calling ring group 603 which just has that BB EXTENSION in it in the “extension list”, 9001# , it does not let me confirm.

It confirms calls ONLY when the “Destination if no answer” is set to Hangup and not if that’s set to move on to the next guy’s cell phone (next ring group)

Also, I had it working this way, and simply changed the name and reloaded and it killed it. Tried recreating and as long as you don’t change anything it works, but even a minor change kills it.