Can't billing for the call between 2 PBX

Dear all !
i have a problem , when making call from Site A(setup A2B) to Site B (don’t setup A2B), Call-center caution “Please enter the number you wish to call, then press the pround key” the hangup. But when making call from Site B to SiteB so OK, billing the call.
this is call- log:

Connected to Asterisk 10.5.0 currently running on localhost (pid = 1988)
Verbosity is at least 3
– Unregistered SIP ‘84932222’
– Registered SIP ‘84932222’ at 192.168.1.1:57956
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] DeadAGI(“SIP/84932222-00000000”, “a2billing.php,1”) in new stack
[2012-07-20 09:55:37] WARNING[2063]: res_agi.c:3937 deadagi_exec: DeadAGI has been deprecated, please use AGI in all cases!
– Launched AGI Script /var/lib/asterisk/agi-bin/a2billing.php
– <SIP/84932222-00000000> Playing ‘prepaid-enter-pin-number.gsm’ (language ‘en’)
– Playing ‘prepaid-you-have’ (escape_digits=#) (sample_offset 0)
– <SIP/84932222-00000000> Playing ‘digits/90.ulaw’ (language ‘en’)
– <SIP/84932222-00000000> Playing ‘digits/8.ulaw’ (language ‘en’)
– Playing ‘dollars’ (escape_digits=#) (sample_offset 0)
– Playing ‘vm-and’ (escape_digits=#) (sample_offset 0)
– <SIP/84932222-00000000> Playing ‘digits/70.ulaw’ (language ‘en’)
– <SIP/84932222-00000000> Playing ‘digits/6.ulaw’ (language ‘en’)
– Playing ‘prepaid-cents’ (escape_digits=#) (sample_offset 0)
– <SIP/84932222-00000000> Playing ‘prepaid-enter-dest.gsm’ (language ‘en’)
– Playing ‘prepaid-you-have’ (escape_digits=#) (sample_offset 0)
– <SIP/84932222-00000000> Playing ‘digits/4.ulaw’ (language ‘en’)
– <SIP/84932222-00000000> Playing ‘digits/hundred.ulaw’ (language ‘en’)
– <SIP/84932222-00000000> Playing ‘digits/90.ulaw’ (language ‘en’)
– <SIP/84932222-00000000> Playing ‘digits/3.ulaw’ (language ‘en’)
– Playing ‘prepaid-minutes’ (escape_digits=#) (sample_offset 0)
– Playing ‘vm-and’ (escape_digits=#) (sample_offset 0)
– <SIP/84932222-00000000> Playing ‘digits/40.ulaw’ (language ‘en’)
– <SIP/84932222-00000000> Playing ‘digits/8.ulaw’ (language ‘en’)
– Playing ‘prepaid-seconds’ (escape_digits=#) (sample_offset 0)
– AGI Script Executing Application: (DIAL) Options: (SIP/TrunkNghi83/84933334,60,HRrL(29628000:61000:30000))
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/TrunkNghi83/84933334
– Executing [[email protected]:1] Set(“SIP/TrunkNghi83-00000002”, “__FROM_DID=84933334”) in new stack
– Executing [[email protected]:2] NoOp(“SIP/TrunkNghi83-00000002”, “Received an unknown call with DID set to 84933334”) in new stack
– Executing [[email protected]:3] Goto(“SIP/TrunkNghi83-00000002”, “s,a2”) in new stack
– Goto (from-pstn,s,2)
– Executing [[email protected]:2] Answer(“SIP/TrunkNghi83-00000002”, “”) in new stack
– SIP/TrunkNghi83-00000001 answered SIP/84932222-00000000
– Executing [[email protected]:3] Wait(“SIP/TrunkNghi83-00000002”, “2”) in new stack
– Executing [[email protected]:4] Playback(“SIP/TrunkNghi83-00000002”, “ss-noservice”) in new stack
– <SIP/TrunkNghi83-00000002> Playing ‘ss-noservice.gsm’ (language ‘en’)
[2012-07-20 09:56:23] NOTICE[2069]: manager.c:2461 authenticate: Seems to have passed…
– Executing [[email protected]:5] SayAlpha(“SIP/TrunkNghi83-00000002”, “84933334”) in new stack
– <SIP/TrunkNghi83-00000002> Playing ‘digits/8.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/4.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/9.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/3.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/3.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/3.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/3.gsm’ (language ‘en’)
– <SIP/TrunkNghi83-00000002> Playing ‘digits/4.gsm’ (language ‘en’)
– Executing [[email protected]:6] Hangup(“SIP/TrunkNghi83-00000002”, “”) in

Asterisk 10 and a2billing, that’s a pretty cutting edge system.

Are you even running FreePBX?

What do you mean ? i running 2 server PBX… but i can’t billing from Site A(setup A2B) to SiteB( don’t setup)

It looks like you are running a2billing software. Is that not what your question is?

I guess we don’t understand “can’t do billing”

Thanks you!
i mean how to bill when call trunk 2 PBX

be more explicit in what your trying to do. Are you trying to setup a2b on server 1 and when its used bill the call but make it go through a “provider” at say server 2 and have those calls billed as well??