FreePBX | Register | Issues | Wiki | Portal | Support

Can't apply config after upgrade to 14


(Andrew Watson) #1

Hi,

I upgraded my backup system to test using this guide:

https://wiki.freepbx.org/display/PPS/Upgrading+from+FreePBX+10.13.66+to+SNG7#UpgradingfromFreePBX10.13.66toSNG7-StartingUpgrade

We have a number of custom destinations that seem to be causing an issue.

The dash board shows:

DEST STATUS: ORPHAN
Follow-Me: 359 (XXXXXX)

I get the following errors when I select Apply Config:

exit: 1
Unable to continue. Illegal string offset ‘target’ in /var/www/html/admin/modules/customappsreg/functions.inc.php on line 59 #0 /var/www/html/admin/modules/customappsreg/functions.inc.php(59): Whoops\Run->handleError(2, ‘Illegal string …’, ‘/var/www/html/a…’, 59, Array) #1 /var/www/html/admin/libraries/usage_registry.functions.php(300): customappsreg_getdestinfo(‘ivr-5,s,1’) #2 /var/www/html/admin/libraries/usage_registry.functions.php(351): framework_identify_destinations(Array, Array) #3 /var/lib/asterisk/bin/retrieve_conf(818): framework_list_problem_destinations(Array, false) #4 {main}

I was able to resolve the error occurring from apply config by removing restapp, endpoint, and customappsreg and reinstalling them using fwconsole. If I attempt to install endpoint directly after the update it indicates an error with column in it’s table called htek.

Column not found: 1054 Unknown column ‘htek’ in ‘field list’::

Moreover, using fwconsole to reinstall these modules results in ALL my custom destinations reporting as errors in the dash board, as well as IVRs and other places that they are used.

I also attempted to reinstall findmefollow with fwconsole. But that seems to have no impact.

I re-entered some of them which appeared to resolve the errors in the IVR. There are 103 reported errors so I am hesitant to re-enter them all manually. Additionally, this seems to break a number of our ring groups and voice mail destinations.


(Andrew Watson) #2

I’ve also run the post-upgrade repair script.


#3

I suggest you uninstall/delete customapps to go forward, you can then reform anything needed properly when you later re-add it.


(Andrew Watson) #4

Yeah, I think that’s what will need to happen.

Do you think there is a way to setup the custom destinations without doing it manually?


#5

Surely “custom” anything would need to be manually set up. No?


(Andrew Watson) #6

I guess. It hasn’t been a problem through updates in the past.


(system) closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.