Can't Apply Config After Update

So I ran some modules updates this morning and now I can’t apply the config and I’m stumped. Before I start ripping things apart I thought I’d see if anyone on here had any thoughts.

FreePBX: 10.13.66-19 (Edge Mode)
Asterisk: 13.18.3

exit: 255
PHP Fatal error: Call to undefined method extension::extension() in /var/www/html/admin/libraries/extensions.class.php on line 1414
Whoops\Exception\ErrorException: Call to undefined method extension::extension() in file /var/www/html/admin/libraries/extensions.class.php on line 1414
Stack trace:

  1. () /var/www/html/admin/libraries/extensions.class.php:1414
1 Like

The current edge framework has a bug, which is the type of thing you experience on rare occasions when setting your system to edge mode. Fix with:


edit - Fixes for both 13 and 14 are now published to edge. Anyone with this issue should be able to fix with:

fwconsole ma --edge upgrade framework

Thank you so much! That totally fixed it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.