Cannot use cell phone to access voicemail

If a user calls into our system using a land line, he is able to access his voicemail using *98. Using a cell phone, the same user cannot enter *98. The user hears an ‘invalid option’ error message. This is true for all callers using a cell phone.

This is not limited to voicemail. Someone using a cell phone cannot enter an extension number.

Rather than exposing your voicemail to the outside world, which I guess you could do with an inbound route, maybe consider a DISA? This will solve your vm and calling other extensions issue in a more secure manner.

I don’t think I explained this correctly. If a customer calls in from a cell phone, they’re not able to enter the extension number for the person they’re trying to reach. They’ll get an ‘invalid option’ message. It works fine if calling from a land line.

Try DTMF=auto or dtmfmode=auto whatever the proper context is.

That did not resolve the issue. The message we’re receiving on the cell phone is “We have not received a valid response. Please try again”.

IIRC, this shouldn’t work from a land line either. There are new options on the IVR module (four or five months ago) that make direct dialing from an IVR only work with extensions. This should preclude you from using the ‘*’ key in the IVR.

I shouldn’t have mentioned the pressing of the * in my initial message. Someone dials into the system from a cell phone, enters 1234 as an extension number and gets this error. From a land line, dial 1234 and the caller gets connected to the correct extension.

OK - there’s an option in the IVR page about Force Strict Dial Timeout and setting it to No-Legacy (Bugs, Bugs, Bugs in FreePBX! (RANT) is one example). This should help.

If you search for “IVR Legacy”, you’ll find a bunch threads about issues like this one. I don’t remember one that was as particular as yours, but check them out and see if anything rings true.

If it works from landlines and not from cell phones it has nothing to do with the IVR. Try dtmfmode=inband on the trunks if auto didnt work. Its not good to use unless you have to but it likely will fix the problem.

1 Like

Thank you for the reply. This still did not fix the problem. I’ve tried combinations of the dtmfmode and ‘force strict timeout’ and cannot get a combination that works.

Does the log show FreePBX receiving the input on a cell call?

Enable DTMF logging in your logs. If you arent seeing the DTMF show up as inband or rfc3833 in the logs from cell carriers but you do from land lines Id reach out to your sip carrier.

Its possible your sip carrier is set to rfc3833 only but the carrier sending them the call is sending in inband. Ive had it happen before.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.