FreePBX | Register | Issues | Wiki | Portal | Support

Cannot update FreePBX anymore


#1

Hi,

FreePBX can no longer update when going to GUI > Admin > System Updates > Check Online.

The page shows:
Current System Update Status: Idle
Last Online Check Status: 3 minutes ago (Yum Error)
Last System Update: Unknown (System updates not run since last reboot)
Updates Available: Unable to run ‘yum check-updates’, can’t check for updates

I updated all modules to the latest version (this works).

When I try to run yum update or yum check-updates I get the error:
Cannot find a valid baseurl for repo: base/7-5.1805.02.el7.sangoma/x86_64

I tried running fwconsole chown and fwconsole ma updateall which both run without errors.

The server is rebooted/reloaded several times now.

Im running official distro: PBX Firmware: 12.7.5-1902-3.sng7

Anyone have any idea on how to fix this?


(Cyberdocwi) #2

Hello,

I would look at DNS and/or routing that may be an issue. You mentioned that when you try to run YUM manually, that you are getting an error. Perhaps the system cannot find it.

Check your DNS: cat /etc/resolv.conf and see what is listed there. Try pinging some random address such as foxnews.com or cnn.com and see if they resolve. If not, you may have a DNS issue.

You may also have a corrupted yum config file, but that is unlikely, as it should be locked to the root user, and wouldn’t be changed often.

Let us know!

Christian


#3

Hi Christian,

Thanks for you reply. I ran yum to update the system. All went fine and when logging though SSH I see:

±-----------------------------------------------------------+
| Your system is currently up to date! |
| Your PBX is up to date. |
| Also 37 Disabled modules and 1 Uninstalled module.

So the last yum update went fine. However the dashboard didn’t reflect this so I tried to yum again and thats when the error came out. So it looks like that last update broke the updates.

I pinged several addresses and all are working fine.

The resolv.conf has 8.8.8.8 and 8.8.4.4

fwconsole ma upgradeall still works after the updates.


(Dave Burgess) #4

Module admin and Yum updates are different, historically.


#5

I understand the confusion. I mean the first screen when you SSH that says

| Your system is currently up to date! |
| Your PBX is up to date. |
| Also 37 Disabled modules and 1 Uninstalled module.

Now it says Your System is currently up to date instead of xx updates pending.

So thanks for clearing this up for the people who think that my yum isn’t working because I mixed dashboard and initial SSH screen. I just meant that when I SSHéd after the yum upgrade nothing changed that’s why I ran it again. Then it said no more updates available and since then YUM is no longer working.


(France) #6

I have the same issue…
All good from a DNS point of view.

No issue before this update, but since this stuff was installed yum refuses to launch.

Is there a way to disable base/7-5.1805.02.el7.sangoma/x86_64 ?
I have not found this repo in the repo files…

Thanks.


#7

I booted a snapshot from 2 weeks ago. Run YUM > goes ok > run YUM again > YUM Broken.
So somewhere the YUM gets broken with the YUM upgrade.

Is there someone at sangoma that can tell us if it’s safe to disable the base/7-5.1805.02.el7.sangoma/x86_64 repo in order to be able to update again?


(France) #8

Up ! Up!


(Dave Burgess) #9

Since you’re not getting any pointers, it sounds like it’s time for a ticket. You should submit an Issues ticket and explain what you did that got you to this juncture.


(Andrew Nagy) #10

No as because tickets are not a “support” queue. Tickets are for reproducible issues. This is not reproducible.


(France) #11

So how do we move from here ?

Is there a way to uninstall yum and reinstall it ? Disable that " baseurl for repo: base/7-5.1805.02.el7.sangoma/x86_64" module ?

We are already 2 of us with the same issue. That is a series :frowning:


(France) #12

[solved]

This is what I simply did. I disabled permanently the repos that YUM failed to find (6-7 to remove).

Then Yum updated itself the failing repo and now all is working


#13

When I enable the base url in the repo I get:

failure: repodata/repomd.xml from base: [Errno 256] No more mirrors to try.
http://mirror.centos.org/centos/7-5.1805.02.el7.sangoma/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found


(Andrew Nagy) #14

mirror.centos doesn’t know anything about Sangoma. That’s why you have this error. Not sure how you even got into this state.