Cannot send SMS trough my Freepbx server

configuration
Tags: #<Tag:0x00007f7025e3ea80>

(Toure Amidou) #1

Hi
I’m trying to send SMS trough mu freepbx server using this tutorial http://forum.thewebmachine.net/enable-sip-sms-support-this-is-not-cellular-sms-t42.html
But It seems not to be working and I don’t receive any information on asterisk console so I don’t know from what come the problem.I proceed like this :
Image 1 ==> asterisk advanced settings
In /etc/asterisk/extensions_custom.conf :
[astsms]
exten => _.,1,NoOp(SMS receiving dialplan invoked)
exten => _.,n,NoOp(To ${MESSAGE(to)})
exten => _.,n,NoOp(From ${MESSAGE(from)})
exten => _.,n,NoOp(Body ${MESSAGE(body)})
exten => _.,n,Set(ACTUALTO=${CUT(MESSAGE(to),@,1)})
exten => _.,n,MessageSend(${ACTUALTO},${MESSAGE(from)})
exten => _.,n,NoOp(Send status is ${MESSAGE_SEND_STATUS})
exten => _.,n,GotoIf($["${MESSAGE_SEND_STATUS}" != “SUCCESS”]?sendfailedmsg)
exten => _.,n,Hangup()
;
; Handle failed messaging
exten => _.,n(sendfailedmsg),Set(MESSAGE(body)="[${STRFTIME(${EPOCH},%d%m%Y-%H:%M:%S)}] Your message to ${EXTEN} has failed. Retry later.")
exten => _.,n,Set(ME_1=${CUT(MESSAGE(from),<,2)})
exten => _.,n,Set(ACTUALFROM=${CUT(ME_1,@,1)})
exten => _.,n,MessageSend(${ACTUALFROM},ServiceCenter)
exten => _.,n,Hangup()
exten => _.,n,Hangup()
I tried to send SMS trough the sip line using linphone softphone but It doesn’t work
Need help to solve the problem
Thanks


#2

You might not see output there if your logging is turned off. You can increase that on the Asterisk CLI:

asterisk*CLI> core set verbose 5

Also check in the /var/log/asterisk/messages and /var/log/asterisk/full files. General log settings are in /etc/asterisk/logger.conf files.


(Tom Ray) #3

Or the answer is right there in the OPs post. The SIP setting is misspelled, outfcall_message_context should be outofcall_message_context. Misspelled settings are invalid settings and are ignored. Messages would never hit that context to be handled.


(system) closed #4

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.