Cannot place calls


I’m a neophyte so my apologies if the following has an obvious solution, but I’ve been struggling with it for hours. I am using FreePBX on a Raspberry Pi with SIP trunking from Twilio. Have been able to get the PBX configured and place calls. But I can’t receive calls. The Pi is behind a router connected to the cable companies modem. It has a static IP address on the subnet. The router’s IP address might change, but should be stable for a day or so at a time, and this configuration is just for testing. I configured the SIP trunk with an origination URI that references the router’s external address. I have seen several contradictory descriptions regarding the need for port forwarding, but tried it both ways. I have also seen contradictory explanations regarding the need to list every possible originating IP address for the trunks (some documentation says there should be a separate trunk for each of the 4 IP addresses at Twilio that may originated the call. For each, I have something like this under the Incoming tab under sip settings for the trunk:
With the setup, when I try to place the call, I get a “all circuits are busy” message.
Would appreciate any advice on this, since the documentation as mentioned is conflicting and I’ve been beating my head against this wall all afternoon. Thanks very much in advance.

Matthew Fleming

Sorry, just to be clear, what I mean is that I cannot call into the PBX from outside. I can make calls from the PBX to outside.

Please check the routing for outbound call setting and trunk for outgoing call.