FreePBX | Register | Issues | Wiki | Portal | Support

Cannot hear voice of incoming call


(Robert Woodcock) #1

I began setting up a FreePBX install some time ago and today have spent sometime getting it working with SIPGATE here in the UK.

all the internal calls work; i can make calls out and receive calls in … however I cannot hear any sound from the external call.

I have a firewall and have opened ports 10000 to 20000 and 15000 to 30000 along with 5060 (udp and tcp) locked to the ip address of sipgate.

Any suggestions would be appreciated; or question of the sort of information that may help you help me?

Cheers
Robert


(Dave Burgess) #2

Say that again, but assume we don’t know what your talking about…

Opening 10000 -> 20000 on the firewall is good, but you need to port forward that range to your PBX. There’s no requirement for opening 15000 -> 30000 on the PBX, so that’s a little confusing. Also, you need to make sure the internal firewall on the PBX is open to your firewall. Generally speaking, if your phone is recognizing an incoming call is being sent to it, the Channel Driver setup is correct, but if the inbound audio isn’t making it, there could be a problem with the NAT settings on your Channel Driver page or the NAT setup on your firewall.

In addition, you need to be specific about which channel driver (PJ-SIP or Chan-SIP) is allocated to which UDP 5060/5160 port. It looks a little like you’re trying to use the PJ-SIP driver, but there’s something funky in your inbound routing and channel driver setup.


(Robert Woodcock) #3

Hi Dave,

After configure my router firewall; I now have a functioning FreePBX install … I had to open some ports to allow the voice to pass the NAT of my firewall!

Thanks for your thoughts.

Maybe you can answer a current question I have; now I have this working with a SIP trunk, can I set a time limit on a calls duration … simply to make sure calls are always hung up.

Robert


(Dave Burgess) #4

There are some ways to limit calls, but the “time limit” thing is usually associated with voicemail.

Look in the Advanced Settings - you may have to turn on the “readonly” settings. I’m not aware of a specific settings, but there’s a lot of settings, so let us know.


#5

Your trunk provider may have this option. I know voip.ms does.


(Robert Woodcock) #6

Thanks … I have had a look in the advanced settings but could not see anything that could be a timeout. The truck provider does not have a timeout either … I think this would be a good feature as this would help protect with a line being left open!


(Robert Woodcock) #7

Unfortunately, the trunk provider does not have a timeout setting.