Cannot get SIP Trunk working

Hello, i’m having massive problems with connecting to my SIP Service to receive inbound calls from a pots number i’m renting from SIP provider. I have got some settings from them but they are not really familiar with Asterisk/FreePBX (they lean towards wanting you to rent their virtual switchboard instead).

I have programmed in the settings the service have given me to create a SIP Trunk, I have created an inbound route which directs to my IVR. When I call the number from a standard landline it gives me the american voice “the number you have dialed is not in service” (I think this is returned from my asterisk server rather than theirs).

I have looked within the SIP logs and I can see that the call is hitting the asterisk server (see links below for logs). It is not however routing to my IVR. I have tried changing the forwarding route from IVR to extension but this has not resolved the issue.

I was advised that the provider is not behind NAT so I have programmed in nat=no into my configuration, this hasn’t resolved the issue either. The following is diagnostic information:

SIP Show Registry: Discover gists · GitHub
SIP Debug: Discover gists · GitHub

The following are screenshots of the trunk setup: (Page 1) (Page 2) (Page 3)

The following are the settings I have for the inbound route:

—Potential problems (derived from logs):—

  1. [2013-06-28 06:15:25] NOTICE[5572][C-0000002e]: channel.c:4257 __ast_read: Dropping incompatible voice frame on SIP/ of format ulaw since our native format has changed to (alaw)

Also - I have disallowed all and allowed alaw from within my extension but this has not made a difference. I also have a second any/any inbound route to make the 7777 simulate inbound call work.

Any help would be greatly appreciated.

Kind Regards,


The provider had told me to put ***'s around my username:


the stars should not exist within the trunk settings.

No, the ***'s were to call your attention to changing the field.