Cannot figure out how to route calls to PRI Card?


(Xarkorrn) #1

So, I have a Digium TE131 card that seems to be recognized by my fresh FreePBX install. I’m sure there is something I’m missing, but I am use to creating Inbound Routes by creating destinations such as extensions, etc. I can’t seem to figure out how I can get calls routing to the PRI card?

Am I just being dense and missing something obvious?


(Xarkorrn) #3

Wow. It just dawned on me that I did not give enough information here and that what I’m trying to do might not be possible.

Essentially, I have a legacy telephony system that EXPECTS a pri going in to it. Currently, we are using an Adtran, which is failing a bit so we were looking to replace it with a FreePBX system with a PRI card. Essentially, what I’m trying to do is route calls from a trunk out through the PRI to the legacy system and vice versa, the same way that the Adtran does. Is this not possible? I can’t seem to find any information about sending the calls from the trunk OUT through the PRI. I assumed it would be a Destination like anything else but I’m beginning to think I’m conceptualizing it wrong.


#4

So you want this path?

PSTN trunk of some sort ->>>> Asterisk —> PRI ---->> legacy PBX
and
legacy PBX —> PRI ----> Asterisk----trunk to PSTN

Is this correct?


(Xarkorrn) #5

This is entirely correct! Exactly!


(Dave Burgess) #6

Yeah, but it isn’t configured.

As much as I love the Dahdi module, I’m still a firm believer in using the Dahdi tools in a stand-alone configuration and getting everything working there, then connect with Asterisk and leave the config of the PRI alone.

DAHDI is a process that lives external to Asterisk, so getting it going using the native tools works well in my head, and experience tells me that it’s a shorter path than clicking on the same three or four buttons in the GUI hoping something new happens.


#7

So that is the first thing to test, can a phone on asterisk call out the PRI line to the legacy PBX (and vice versa…)


#8

Oldie but goldie . . .


(Xarkorrn) #9

@nielsen I guess that’s sort of my problem. I’m uncertain as to how I go about directly incoming or outgoing calls through it? As an example, typically for inbound routes, when I’m testing, I will set the destination to an extension and everything works out. Or with outbound, I just tell it which trunk I want the calls to go out on. I can’t seem to make the connection of how to tie the pri into that equation?

UPDATE BEFORE I POST THIS: Okay, before posting, I did a bit more digging. I noticed that there was a DAHDI Trunk in the Trunk creation menu. Now, I went in there and looked around, but I was still confused because I expected to see a “Device” selection and I didn’t find that. However, I then noticed that under dahdi Settings, there is a identifier setting that is, by default, set to g0. I went in to the configuration of the pri card and noticed that it’s “group” is set to 0. Is it safe to assume that this is how I get the PRI in to the mix? By creating a DAHDI Trunk for group 0? In that way, I could select that trunk as a destination, so I think the setup would look something like this:

Inbound Route: PSTN Trunk -> g0 Trunk -> Legacy PBX
Outbound Route: Legacy PBX -> g0 Trunk -> PSTN Trunk

Is that correct or partially correct?

Thank you again for your help. It’s much appreciated.


(Dave Burgess) #10

When you set up the DAHDI trunk, you will specify the group number that’s associated with the group on the trunk. So, you’ll never see a ‘device’; you’ll only see the line groups that the DAHDI API presents to Asterisk.

So, the DAHDI interface allocates the group or groups (or line(s)) that are associated with the PRI Channels. These are how you connect the ‘trunk’ definition to the PRI. This means you first have to get the card working. It needs to show ‘green’ in the stand-alone dahdi programs. Once you’ve got the group defined in DAHDI, your trunk definition should pick up the group(s).


(Xarkorrn) #11

@cynjut Okay, that makes sense, in terms of it showing green, as initially it said UNCONFIGURED and now is reading RED.


(Xarkorrn) #12

@cynjut In terms of the call flow that I posted near the bottom of that post, is that the right thinking or am I way off?


#13

Framing, signalling and master clock all need to agree betwixt your DAHDI trunk and the PBX to get a ‘green’


(Xarkorrn) #14

@dicko Thank you for this. I talked to my partner (he’s the old school telephony guy, I’m primarily a developer) and he has all of the appropriate settings and understood everything you mentioned. I now have an OK from the loopback device and we are going to hook it up to the actual PBX tomorrow (It’s a 24/7 TAS, so we have to be careful about testing too much on the live system). It’s a start. I’m sure I will have more questions after that, but thank you so much for your help. I am truly grateful.


(Xarkorrn) #15

@cynjut Thank you, again. Showing green with a loopback device and OK in FreePBX. Going to hook it up to the live system tomorrow to move forward.


#16

I will mention that after you disconnect the T1 from the wall, you will need to choose one master clock which probably the PBX assumes ‘the wall’ (AKA DAHDI now), either your PBX or DAHDI must be the master or you will start to see ‘slippage’