Cannot dial through an IVR

This is a new install of 10.13.66-1 using Asteisk 13.7.2. The install is less than a week old. We are using SIP trunks set for dtmfmode=rfc2833. When they dial into an IVR somewhere (example was an insurance company) they cannot dial through the ivr. The SIP trunk provider provided a PCAP and there is no payload when she is dialing digits on a call. I have never heard of this problem. of course I have not heard of a lot of things, but that is for another day. Anyone else have this problem??


you can test by make other calls, and pick up the call, press any dtmf keys to test.

No matter which way we make the call the DTMF is not sent

Was the call ending when they would try to dial any numbers? I had a similar situation the other day where whenever they’d end up in an IVR and tried to enter something the call would end. The logs just said hang up. Upgrading to 10.13.66-9 seems to have fixed it (along with a bunch of other issues we were having).

Nope the call didn’t end. In fact in the pcap I have they tried twice once on just a call between two people and then conferenced to another IVR. There just isn’t any DTMF, wierd

Could be a carrier issue. I’ve had that happen a few times, where for a few hours DTMF tones will just not work. Sometimes “resetting” the trunks helps too. Go into the trunk definition and just save it, with or without making a change.

It appears that we had to set the phone as SIP Info instead of RFC2833 and the issue was solved. Probably going to look at other customers with similar phones and trunks

Eventually it boiled down to the settings in the phone. we had to set it up as SIP Info instead of RFC2833. Then it worked.