Cannot check for updates, yet again


(Jared Busch) #1

This is getting really old.

WTF is going on with your infrastructure…

image

So I drop to the command line…
image

And then check in the GUI again…
image


#2

We have a maintenance window tonight and are running into the same thing, nothing like repos being down exactly when you need them to not be…


(Preston McNair, ClearlyIP CRO) #3

@hbonath in a pinch, you can switch over to the CIP Mirrors (Free Service, open to the world, not just our customers). https://kb.clearlyip.com/FreePBX/Switching-to-Clearly-IP-Mirrors-for-FreePBX.html


(Matthew Fredrickson) #4

Friday night is a crazy night from a load perspective for the mirror infrastructure. I think there’s a substantial portion of the FreePBX universe that tries to update that night. We’ve already been through a number of upgrades to it, but it sounds like we have a few more pieces that need some improvements.

Sorry about the trouble - you might also try pointing to the newer infrastructure (mirror1 is the legacy mirror infrastructure) if you haven’t tried it yet. It’s built in a bit more of a scalable way than the old mirror1 server:

fwconsole setting MODULE_REPO https://mirror.freepbx.org

Best wishes,
Matthew Fredrickson


(Jared Busch) #5

It was not Friday night. Time in CST.
image


(Jared Busch) #6

Production systems use production code. So if you want my systems to use this mirror, then you need to push it out.


(Matthew Fredrickson) #7

It’s not a production versus not production issue - the newer mirror infrastructure is production code and is used by default by many systems. There are just some legacy functions that the old mirror1 server provides to older systems that are not part of the newer infrastructure, IIRC.

Matthew Fredrickson


(Jared Busch) #8

That system listed above is a fully patch FreePBX 15 system and it is using what it is using.

If you want it to not use that, you need to update things that point to them.

Manually changing settings means the system is suddenly custom. Now that information has to be tracked by the maintainer (my company) that this is now a snowflake system and not default.

That is not a scalable solution.


(Matthew Fredrickson) #9

In FreePBX 15, new installs use that as the setting for the repo by default, but it’s possible that you migrated forward using backup/restore or another method (or installed prior to the point where it was made default) and that you didn’t get that change.


(Jared Busch) #10

Right, I get that it may be currently default. That does not change anything I said.

In fact this system was at least FreePBX 14 originally. If not FreePBX 13. I do not recall without digging into the client history. But again, if you (Sangoma/FreePBX team) want this to be the global default, you need to make the updates to make it so.


(Matthew Fredrickson) #11

That’s not a bad thought, probably something we should consider doing.

Matthew Fredrickson


(Dave Burgess) #12

Isn’t part of the problem that FreePBX sets the default update time for Friday nights? The system itself (IIRC) sets that update day and time, and then (surprisingly) the system gets really, really busy around then.

It’s been failing like this (every Saturday) for a long time.


(Matthew Fredrickson) #13

Yes - by default, it selects a random time within a window that is somewhere within the friday “night” period (where night I think is timezone dependent, so realistically it could be friday daytime for others, and various other versions of that problem).

Matthew Fredrickson


#14

I’m having the issue with downloading updates on a 15 box that I recently did a restore to from a 13 backup. I tried resetting the repo to https://mirror.freepbx.org but still no luck.
Is there something else that needs to be done to get updates working again?
Thanks!