Cannot activate new install FreePBX 12

I have a new install of FreePBX 12.x and cannot get the install to activate. I seem to be stuck in a loop. I goto the Admin > System Admin > Activation page. If I have never been to this page in this login session I can click the activate button and will take me to the next page that asks if I want to activate or skip. If I click activate I end up back on the first page and no error messages.From this point on clicking the activate button just refreshes the page. I have tried Chrome and IE and both act the same.

I updated all modules to the most current.

Any ideas?

I have experienced the same problem this afternoon. The operation seems to be very erratic, sometimes it takes you to the next step, other times it just reloads the same screen. There does not seem to be any particular pattern in the behavior.

This is driving me nuts, I have now loaded the distro with freepbx13 onto a test box (I was using freepbx 12 before) and the same thing is happening, I am unable to activate the system, it just reloads the page when I try to activate. Is there something I am missing here?

Would be really grateful if someone has some suggestions.

Are you using Safari? (Don’t use Safari)

No. I am running Windows 10 and have tried using Firefox, Chrome and Edge. All exhibit the same behavior.

OK, that’s a problem then. It’s probably best to grab me on IRC for that, as that should never happen!

IRC is an interactive chat thing, were you can yell at me directly for breaking your stuff! A web client is available here:

Just type “?staff” or “xrobau” or “x-rob” and I’ll get alerted that you’re looking for me

Rob thanks. I can see from wireshark that my system does interact with Schmoozecom when I try to activate it:

48.349147 -> TCP 74 50258 > https [SYN] Seq=0 Win=14600 Len=0 MSS=1460 SACK_PERM=1 TSval=239676334 TSecr=0 WS=128
48.422017 -> TCP 74 https > 50258 [SYN, ACK] Seq=0 Ack=1 Win=14480 Len=0 MSS=1380 SACK_PERM=1 TSval=3304943150 TSecr=239676334 WS=128
48.422056 -> TCP 66 50258 > https [ACK] Seq=1 Ack=1 Win=14720 Len=0 TSval=239676407 TSecr=3304943150
48.458920 -> SSL 210 Client Hello
48.531331 -> TCP 66 https > 50258 [ACK] Seq=1 Ack=145 Win=15616 Len=0 TSval=3304943260 TSecr=239676444
48.535941 -> TLSv1 1434 Server Hello
48.535970 -> TCP 66 50258 > https [ACK] Seq=145 Ack=1369 Win=17408 Len=0 TSval=239676521 TSecr=3304943264
48.536203 -> TLSv1 3989 Certificate
48.536252 -> TCP 66 50258 > https [ACK] Seq=145 Ack=5292 Win=20352 Len=0 TSval=239676521 TSecr=3304943264
48.567830 -> TLSv1 264 Client Key Exchange, Change Cipher Spec, Encrypted Handshake Message
48.642223 -> TLSv1 125 Change Cipher Spec, Encrypted Handshake Message
48.642789 -> TLSv1 183 Application Data
48.755949 -> TCP 66 https > 50258 [ACK] Seq=5351 Ack=460 Win=16640 Len=0 TSval=3304943484 TSecr=239676628
48.801067 -> TLSv1 972 Application Data, Application Data
48.801089 -> TLSv1 103 Encrypted Alert
48.801098 -> TCP 66 https > 50258 [FIN, ACK] Seq=6294 Ack=460 Win=16640 Len=0 TSval=3304943529 TSecr=239676628
48.802033 -> TLSv1 103 Encrypted Alert
48.802149 -> TCP 66 50258 > https [RST, ACK] Seq=497 Ack=6295 Win=23040 Len=0 TSval=239676787 TSecr=3304943529

Will try to chat with you.

I believe this is a Firewall or NAT issue, I put the system directly on the Internet without a NAT or Firewall and immediately was able to activate. I am now trying to understand why the system would not activate when behind the NAT. Can anyone help me to understand this?

Sounds like something was intercepting HTTPS traffic in your NAT/firewall, in that case.

I did see you comment on IRC, but I was already asleep - you were pinging me at 11:30pm my time 8)