Cannot activate FreePBX 13 behind network proxy


I just installed FreePBX 13 as a VMware VM in my lab environment. In order to do anything on the Internet I have to go through a network proxy.

There are a lot of topics with the same problem over the last few years. I have read a bunch and set up the following:

  • Edited /etc/profile to add http_proxy, https_proxy, and ftp_proxy
  • Edited /etc/yum.conf to add the proxy
  • Edited /etc/wgetrc to add the proxy
  • Turned on “Use wget for Module Admin” in advanced settings
  • Rebooted the VM after all of this to ensure all processes got the proxy settings

After all of that was in place the /etc/ was able to successfully complete and it deleted itself from the system.

I’ve been able to update the initial distribution of FreePBX and was able to install the SSH Keys package in the remote support section once the proxies were in place.

None of that is allowing me to activate FreePBX. When I click on Activate, a red error box immediately pops up in the upper right corner of the window and then after a pause…

Activation Error!
Unable to display activation page. Error returned was:
connect() timed out!

How do I get around this issue? Is there something else that needs to be done?


David Fox

We do not support activation through a proxy.

Hi Tony!

Thanks for the response. Interestingly, most of the previous posts stated that by doing what I did they were able to activate their FreePBX installation. Is that a more recent change? Some of those posts admittedly are old as they go back to 2011!

Is there an alternative way to activate? There is no way that I can get around the proxy. I’m using FreePBX to help resolve support cases. I’m a Level 3 escalation support engineer for my company.



Let me rephrase my statement. We don’t have any settings specific for dealing with a Proxy for activation. Activation runs through a php script and apache.

LOL! OK. The only issue for me then is that if I need to install or upgrade a commercial package, I can’t. I don’t think it will be a big deal as I’m only going to use this as a destination call processor for 3rd party SIP phones.

Thanks very much for your responses! Have a nice weekend!



Go to advanced settings and try to set this:

Andrew isnt that just for module admin or is this for other things?

It might work for more. @xrobau wrote it so that it sets the proxy in the environment

Ahh was not aware of that? Ya maybe that will be enough for him to get activated.


Thanks! I previously also set that for the lab proxy and enabled it. It had been https but I just went and changed it to http and it didn’t make a difference. I still get the connect() failure.

If you can think of anything else to try I would be happy to give it a go.

Have a nice weekend folks!