Canno make any inbound call via tdm401p

Hi,
I have asteriskNow 3 with freepbx and tdm410p with one fxo interface.
After installing and configuring outbound and inbound routes i can make only OUTBOUND calls and cannot make any INBOUND.
Please need help ugently…

First I would recommend that you install a real version of FreePBX.

Second we need a call trace. What happens when you make a inbound call? How have you configured the TDM401P?

[[email protected] /]# more /etc/asterisk/indications.conf
;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. ;
;--------------------------------------------------------------------------------;

[general]
country=us

[us]
description = United States / North America
ringcadence = 2000,4000
dial = 350+440
busy = 480+620/500,0/500
ring = 440+480/2000,0/4000
congestion = 480+620/250,0/250
callwaiting = 440/300,0/10000
dialrecall = !350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,350+440
record = 1400/500,0/15000
info = !950/330,!1400/330,!1800/330,0
stutter = !350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/100,!0/100,!350+440/10
0,!0/100,350+440


[[email protected] /]# more /etc/asterisk/dahdi-channels.conf
; Autogenerated by /usr/sbin/dahdi_genconf on Sun Dec 29 20:58:19 2013
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: WCTDM/0 “Wildcard TDM410P” (MASTER)
;;; line="4 WCTDM/0/3 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-pstn
channel => 4
callerid=
group=
context=default

;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

[general]

; generated by module
#include chan_dahdi_general.conf

; for user additions not provided by module
#include chan_dahdi_general_custom.conf

[channels]
language=il
busydetect=yes
busycount=10
usecallerid=yes
callwaiting=yes
usecallingpres=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=no
immediate=no
faxdetect=no
rxgain=0.0
txgain=0.0

; for user additions not provided by module
#include chan_dahdi_channels_custom.conf

; include dahdi groups defined by DAHDI module of FreePBX
#include chan_dahdi_groups.conf

[[email protected] /]# more /etc/dahdi/system.conf

-------------------------------------------------------------------------------;

Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;

this file must be done via the web gui. There are alternative files to make ;

custom modifications, details at: http://freepbx.org/configuration_files ;

-------------------------------------------------------------------------------;

fxsks=4
loadzone=il
defaultzone=il

It looks correct but as pointed out need a call trace. “dahdi show channels” would help too.

Have you set up the DID’s using DAHDI Channel DID or are you using an ANY/ANY catchall inbound route. Make sure you don’t have anything in the CallerID Number field of inbound routes. That’s only when you wish to trap a specific Caller ID and send it to its own destination.

BF

For analog lines it would be better to set up pseudo DID’s and use the from-analog context, your /dahdi/system.conf says you want Israeli indications but you try and use US indications in your indications.conf, either clear out or correct indications.conf if you are IL, vise-verse if you are US.

Thank you for respond i will try IL.