Can not pickup incoming call

We are moving from Trixbox to FreePBX and I’m having an issue with the incoming calls, I can call out just fine.

This is my second/third time wanting to get FreePBX up an running, had this test trunk working with FBPX 1.8 and 2.210 and work had to get in the way again. I really want to send Trixbox to the farm, thanks in advance for your help.

The PBX is FreePBX 4.22 with Asterisk 11, would like to stay with Asterisk 11 being its LTS.

When calling in the extension rings but I can not pick up the call, this is what the PBX is seeing, it says I answered but it keeps ringing:

SIP/412-0000002e is ringing
– SIP/412-0000002e answered SIP/

Here are my trunk peer details:


I have “Allow Anonymous Inbound SIP Call” set to yes for now as well. What am I’m I not seeing.

Thanks again


To add to the above,

I just noticed while its still ringing after I tried to pick up the call I can put the call on hold and pick it back up and put it back on hold while it’s still ringing, very strange.

– SIP/412-00000013 is ringing
– SIP/412-00000013 answered SIP/
– Started music on hold, class ‘default’, on SIP/
– Stopped music on hold on SIP/
– Started music on hold, class ‘default’, on SIP/

Added the following to the sip_general_custom.conf file, seem to take care of it.


Well I thought I had it working, I now get the following error message under the settings/asterisk sip settings page in FreeBPX:


Settings in /etc/asterisk/sip_general_custom.conf may override these. Those settings should be removed.

Under the settings/asterisk sip settings page in FreeBPX at the bottom I have a spot to add session-timers=refuse.

Now no other errors that I can find and the trunk is working, now to the next issue.