Can Not Connect to Asterisk following 13 - 14 upgrade


(Justin Smith) #1

Following an upgrade from FreePBX 13 to 14 following the guide here https://wiki.freepbx.org/display/PPS/Upgrading+from+FreePBX+10.13.66+to+SNG7, I get “Can Not Connect to Asterisk” in the GUI.

In the GUI logs, I can see NOTICE[xxxx] manager.c: 127.0.0.1 failed to authenticate as ‘admin’

fwconsole restart gives me “Unable to connect to Asterisk. Did it start?”

I have tried yum update, fwconsole moduleadmin updateall, fwconsole chown, and get the “Asterisk is not connected” error from fwconsole moduleadmin updateall

I have tried ./post_upgrade and get a few “Asterisk is not connected” errors along the way, but it still does not work.

Please can you help?


(Lorne Gaetz) #2

Asterisk manager password in Advanced Settings must match the admin password in /etc/asterisk/manager.conf


(Justin Smith) #3

Thank you so much for your help!

I was able to use nano to change the admin password in /etc/asterisk/manager.conf to match the value in Advanced Settings, and from there everything went much better :sunglasses:

Thanks again for your speedy response.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.