"Can not connect to Asterisk"-Error after automated install of Update 10.13.66-8 and now at ACPI-Shutdown and restart of KVM-Server

Dear all,

right after the automated update to 10.13.66-8 through module System Admin on Saturday at around 6 a.m. it seems that FreePBX must have lost its connection to Asterisk. As we could not phone out on saturday I checked FreePBX-Gui and discovered the error “Can not connect to Asterisk” in FreePBX-GUI.

Issuing command fwconsole start fixed the issue on staurday (even if there were other red notices on FreePBX afterwards; but nothing sounding serious and everything worked).

Second occurence of the same problem I have had a few minutes ago: Due to security issues my hosting provider told its KVM-vServer-Customers to issue an ACPI-Shutdown and Restart to the server for an update to their host-systems. As soon as I have had issued that and restarted the Server FreePBX-GUI worked fine; but again showing Error “Can not connect to Asterisk”. Here as well command fwconsole start has helped.

This seems strange as I have shutdown and restarted the server earlier (before the update to 10.13.66-8) without any connection issues to asterisk; as well as there have been automatic updates without this problem before.

Has something changed on the way of asterisk connection or restarting this connection after updates / server restarts?


Something is causing Asterisk to not start. Can you get to the logs for your server?