Can I change the type of transport?

So I’m having a problem with my webphone. When it register, this is the message on CLI:

== WebSocket connection from 'myip:55886' for protocol 'sip' accepted using version '13'
    -- Added contact 'sip:[email protected]:55886;transport=ws' to AOR '101' with expiration of 600 seconds
  == Contact 101/sip:[email protected]:55886;transport=ws has been created
    -- Removed contact 'sip:[email protected]:53980;transport=ws' from AOR '101' due to remove_existing
  == Contact 101/sip:[email protected]:53980;transport=ws has been deleted
    -- Contact 101/sip:[email protected]:55886;transport=ws is now Reachable.  RTT: 69.304 msec

But when I try to make a call, just right after I allow the permissions on browser, the call finish. What I thought: “transport = ws” should be “transport = wss”. Am I right? And how could I change that?

PS: This is the log on CLI when I try to make a call:

== Setting global variable 'SIPDOMAIN' to 'mydns.mustnotshow.waw.doge'

‘wss’ needs valid ssl certificates installed, ‘ws’ doesn’t , BUT very few modern browsers allow ‘ws’ anymore

1 Like

@dicko, thanks for the reply. I do have a valid ssl certificate, it should’be passing through wss?
https

Also, should I turn SIP NAT on?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.