Can FreePBX ring a desk phone and Zoiper at the same time?

Is there a way to have FPBX ring an existing desk phone and Zoiper on Android at the same time? After installing Zoiper, either the softphone rings or the desk phone rings but not both. The one that rings seems to depend on which one registered last.

The user would like to have both ring so that he can answer the phone at his desk but also have the call on his cell phone if he’s away from his office somewhere in our store.

You can register multiple clients to a single PJSIP extension provided the ‘max contacts’ is set to a number equal to or greater than the maximum number of registrations. Don’t use chan_sip, which at this point shouldn’t be used anyway.


Thanks for your reply! Two questions:

  1. Why not chan_sip? Is that a security problem or something else?
  2. Since all our extensions are set up with chan_sip, do I need to delete the extension and recreate it? Is there a way to convert it?


Chan_sip is deprecated and it does not support multiple registrations. There is an option when you edit the extension to convert to pjsip, which you can do one at a time, and there is a bulk convert tool.

1 Like

Well, Lorne, you’re obviously my new best friend. Thanks for all your help!

1 Like

I’m going to try this on my own extension first because I can rebuild that without too much trouble if there’s a problem. I’m getting this warning. Will this really delete my extension? The document you posted mentions that the warning will be shown but doesn’t go into any detail.


Since converting my extension to pjsip, I can’t connect Zoiper at all.

After putting in my credentials (like [email protected]), it fails when it’s searching for configuration options (SIP TLS/SIP TCP/SIP UDP/IAX UDP). It used to work with SIP UDP.

I’ve tried changing the Transport option in the Other tab on FPBX but that hasn’t made a difference. On chan_sip it showed UDP being available but now all of them are red when it scans for a legit config.

I increased Max Contacts to 3 but only have the first line populated in the Other tab. My desk phone continues to work through all of this for whatever that’s worth.

Can anyone point me to what I need to fix to get this to connect using PJSIP?

Chan_SIP and PJSIP cannot run on the same port. You probably need to update the server port in Zoiper

The solution ended up being stupidly simple like it normally does - specify the port with the IP address even though Zoiper complains about it.

You can use Ring groups. Detailed description is here:

If registering multiple clients to a single PJSIP extension, is there a way to ring one client and not other clients registered to same extension? I would think not, but still curious.

I also use a ring group to ring multiple phones/clients as @Matthai suggested.

No but any one source can be more than one ‘client’


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.