Calltoken error while registering softphone


this topic is more or less related to this one Communication between two PBX-VMs in internal network, but you don’t have to read it to get the point.

I try to register a softphone to my asterisk VM(debian).
Zoiper doesn’t work at all and gives no feedback in the asterisk*CLI.

So I tried SLFphone. When registering to asterisk the following appears:

I read many discussions to this topic and tried a few things.
Set requirecalltoken=no in the extensions’ advanced settings, wrote requirecalltoken=no to the iax_custom.conf, also tried calltokenoptional= and so on.

Any tips? Is there even a ‘calltokenoptinal list’?


Did you try to use SIP instead of IAX?

I just tried, SFLphone gives back the Status: Error.

Don’t I need a SIP trunk so I can use a SIP extension?
This wouldn’t fit my needs. I’ve 2 VM’s on the same PC connected via NAT using iax2-Trunks.

Nevertheless, thanks for your help!

Nope - SIP trunks are only useful when connecting servers together. You can set up SIP extensions in the extensions option under either CHAN_SIP or PJSIP tabs.