Calls transferred to phone won't go to Voicemail

The system is a OEM version 6.12.65.28

The trunks are SIP trunks. Here is what works:

  1. A trunk call can be transferred directly to a voicemail box by transferring to *Ext.

  2. An intercom call can be placed to an available phone and the caller wil go into the voicemail box.

  3. Direct DID calls to an available phone goes to the voicemail box after the ring timer expires, if the phone is idle.

  4. A Transferred trunk call to an available phone can get the call and all is good.

A trunk call that is transferred to an available phone will ring at that phone until the caller gives up. The voicemail boxes are using the extension number for the password, ( I know it is a bad thing, I can’t get the users to change).

I have looked in the user portal and there isn’t anything there IE:Follow me, forwarding. Dialing *ext gets us to the voice mail box.

All the phones had voicemail boxes enabled when the system was installed a couple of weeks ago.

Is there enough info given here to speculate what is going on?

I had a call from a colleague of mine, who also uses FreePBX. They’re having the same issue as you. They do have a temporary workaround by enabling Follow Me on each of their extensions, but the solution still sucks. Follow Me is disabled by default and having to enable it on everyone can be a pain.

I’ll be holding off on this update until this gets sorted out.

We spent some more time at this customers office this morning. It appears that a call that is originally answered from a Ring Group call is affected. All direct ring in DID calls and direct ring in DID calls that are transferred work. Calls from one phone to another also work. Here are my notes:

Called the main number that rang into a Ring Group. Ext 225 transferred the call to 221. Call rang until I hung up at 2 minutes:
Line from the Reports/Asterisk Info/Connections
SIP/ClearRateSIP-000 [email protected]:44 Up Dial(SIP/221,TtrM(auto-blkvm)

Called a DID that rang into ext 225 and ws transferred to 221, after 10 seconds I got the unavailable voicemail.
Line from the Reports/Asterisk Info/Connections
SIP/ClearRateSIP-000 [email protected]: Up VoiceMail([email protected],u)

Setting the VoiceMail “No Answer” in the extension to “Voicemail Unavail to the mailbox” That appeared to be a work around.