Calls tranfered to queue dont ring and go to Voicemail

We recently updated FreePBX from 2.8 to 2.9 to 2.10 and then to 2.11.

Ever since we have been having an issue (looks to be similar if not exactly the same as ) where if a call is transferred to a queue and an agent in that queue is on DND then it will not ring anyone in the queue but will go strait to VoiceMail.

It seems like it is not recognizing someone in DND as unavailable and gets sent directly to there Voicemail.

The weirdest thing is that it does not do this if the a caller calls in to the ivr and goes directly to that queue, but only happens if someone transfers that call to the queue.

I thought it might be issues with Follow me settings, so i disabled all the follow me rules for all agents in the system, but this did not help. We have tried “skip busy agent” settings but no help. It does not seem to be Voicemail ringtime settings as it is longer then the ringtime set for the queue before it would try the next agent. Also caller only ever hears 1/2 a ring and then the voicemail prompt.

Im sure I am missing something, or misunderstanding an option, but not sure where to go from here. All of this worked as expected before the update.

Here are is the info of our system

PIAF Installed Version = under HARDWARE
FreePBX Version =
Running Asterisk Version =
Asterisk Source Version = MODIFIED
Dahdi Source Version =
Libpri Source Version = 1.4.14
IP Address = 10.111.x.x on eth0
Operating System = CentOS release 6.2 (Final)
Kernel Version = 2.6.32-358.18.1.el6.i686 - 32 Bit