FreePBX | Register | Issues | Wiki | Portal | Support

Calls pushed to iax2 trunk require confirmation

configuration
Tags: #<Tag:0x00007fd2e67d3d48>

(Stephen Ingram) #1

I’ve got a IAX2 trunk that connects two FreePBX systems working great. I have unique extensions on each system, however, there is a group of extensions, say 4xx that forwards to 5xx on the other system. I use the custom device for this. For example I have extension 434 that forwards to 534 on other system. In the dial field for the custom device for extension 434 I have local/534@from-internal do that calls are forwarded to the actual physical extension 534 on the other system which actually has a SIP device config on it. However, when queue calls for 434 come in, they are forwarded correctly to 534, but require the recipient to press 1 to accept the call. I’m thinking maybe it has something to do with the call context, but I’m using from-internal on the iax2 trunk so I would think that would work. How do I get rid of the call confirmation requirement?


(Lorne Gaetz) #2

You have ‘Confirm Calls’ enabled in the Queue config, which is probably what you want. Otherwise your external agents can intercept queue calls with their voicemail.


(Dave Burgess) #3

@supersource … and this is bad because then all of your customer calls would end up in that user’s voicemail instead of being handled by an agent.