Calls going into a blackhole

I am having some issues with calls and am basically bald because I have pulled all my hair out trying to solve it. I have done a STFM and not found a solution.

Here is our setup.

Asterisk version 1.4.21.2
Freepbx version 2.5.2.2
Redhat CentOS 4.4 kernel 2.6.18-53.1.13.2.cc

We are using Vitelity for our numbers.

We have one number that goes into an IVR to go to a Grandstream phone.

We have two numbers that goes into a digium TDM410 with a FXS module that has a vtech wireless single line phone system attached to it.

What is happening is driving us [email protected]#!#

It seems that some numbers can call us with no problems. It seems that there are a bunch of numbers that do have issues. When the call comes in, we see it ring on the wireless cid, it rings and we answer it. There is silence. According to the people they hear either a fax signal or a busy signal.

Now here is where it gets even more annoying. This does not happen 100% of the time. Some times these numbers get through with no problems. On the failed calls we get a email from Vitelity stating “congestion” or one that says “busy”

Anyone have any ideas?

Thanks.

dave

You may need to watch your CLI while a call is coming in, or take a look at the logs during these calls and see what happened. Any chance you have a fax machine in line with your cordless phone?

I wish it was as simple as a fax machine being plugged in :slight_smile:

Out of the Digium card all I have is the Vtech base station.

Here is part of a log for a failed call.

I am utterly confused how it can be that it is recording a busy in the log on the answer.

[Feb 27 13:43:53] VERBOSE[11327] logger.c: == Manager ‘admin’ logged on from 127.0.0.1
[Feb 27 13:43:53] VERBOSE[11324] logger.c: dialparties.agi: Caller ID name is ‘5555550019’ number is ‘5555550019’
[Feb 27 13:43:53] VERBOSE[11324] logger.c: dialparties.agi: Methodology of ring is ‘none’
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – dialparties.agi: Added extension 101 to extension map
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – dialparties.agi: Extension 101 cf is disabled
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – dialparties.agi: Extension 101 do not disturb is disabled
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – dialparties.agi: dbset CALLTRACE/101 to 5555550019
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – dialparties.agi: Filtered ARG3: 101
[Feb 27 13:43:53] VERBOSE[11327] logger.c: == Manager ‘admin’ logged off from 127.0.0.1
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – AGI Script dialparties.agi completed, returning 0
[Feb 27 13:43:53] DEBUG[11324] app_macro.c: Executed application: AGI
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – Executing [[email protected]:7] Dial(“SIP/db-0868a510”, “ZAP/1||tr”) in new stack
[Feb 27 13:43:53] WARNING[11324] chan_zap.c: Unable to ring phone: Device or resource busy
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – Couldn’t call 1
[Feb 27 13:43:53] VERBOSE[11324] logger.c: – Hungup ‘Zap/1-1’
[Feb 27 13:43:53] VERBOSE[11324] logger.c: == Everyone is busy/congested at this time (0:0/0/0)
[Feb 27 13:43:53] DEBUG[11324] app_macro.c: Executed application: Dial

The first step I would take is to remove the current phone and replace with a simple wired known to be to good handset and test from those “bunch of numbers”