Calls getting dropped after 20 seconds or more

I am fairly new using Asterisk and FreePBX but so far we have had a good working experience with them.

We have Asterisk 1.6 and FreePBX Most everything is working fine but unfortunately some calls get dropped off after 20 seconds or more. It is not every call and from what I can tell it seems to be to systems that have auto-attendants. Even if you are sending commands and they are being accepted (you are getting routed to the right menu) the call gets dropped off, typically between 20 and 40 seconds from getting connected. I have tried both from soft-phones and physical phones with the same results. I have searched for this issue online but the articles that I have found either do not work for me or are way over my head.

Any light you can shed into this issue will be greatly appreciated.

Please when you answer my question be very detailed and don’t assume that I understand what you are talking about, as I said I am pretty new at this. THANK YOU!!!


Dear Andres,

I have the same problem and i have the feeling that it started from the upgrade to 2.8 version.

please see my post here:

a few days ago i thought it was solved, but now it seems like the problem did not change.

I hope that if there is a solution i will be updated to…

Kind regards,