Calls forarded to Misc. Destination not passing through CID/CNAM information

Hey guys/gals,

I am trying to setup forwarding of calls to a cell phone during “nite mode” for a client. Calls forward with no problem however the CID and CNAM information displayed is our trunk CID and CNAM info, not the originating callers info.

I have tried this two ways, the first way was inbound call hits Call Flow Control, then Set Caller ID, to the cell number. I have also tried inbound call to time condition, to Misc. Destination and neither are working.

I have verified with my trunk provider that they support foreign caller ID information so it is definately something I am doing incorrectly.

Check on your outbound route and Trunk if you force your company CID.


Ok if I set the outbound trunk to be intercompany it will pass along the CID information. However when I do that all outbound calls are just showing the users extension.

Do you know if there is a way to force a miscellaneous destination to use a specific outbound route?

Did yo try setting it like this?

Override Extension > No

1 Like

Yes, for some reason I can only get it to work one way or another. I found another post that alluded to setting up a feature code in an outbound route then forcing the misc destination to use that feature code. I have tried a couple of things in this area but have had no luck.

Not really sure where to put the “feature code” in the outbound route. I though maybe in the prefix of the dial patterns but that didn’t work. Also was not sure how to use the feature code in the outbound dial. If I could force miscellaneous destinations to use a trunk I specify I could work around this issue…just can’t seem to figure that part out. Thanks for all your help PitzKey

To be more specific my outbound route is set to NO on overrride extension. When the extension dials an outside number it passes along their extension number not the company CID. If I turn off intercompany then it will pass the correct CID for the company but it no longer passes along foreign CID from an inbound call that is being sent to a misc. destination.

Can you post a call trace?

Guys, you do realize that each extension has both an Outbound CallerID and an Emergency CallerID field in them? Instead of overriding all the Outbound CID’s at the Outbound Route/Trunk level, just set the CallerID’s on the extension. That way you can have your Outbound Route/Trunk setup to let forwarded CID’s pass through without setting non-needed settings like “Intracompany”.

Those CID fields in the extension are why there is an “Override Extension” option in the Outbound Routes, etc.

That’s a bunch of work if he has alot of extensions.
I never set that unless there’s a need for that extension’s the to be different than the “default” (default = whats set on the outbound route) and I never had CID issues with FollowMe, Misc Destination or any forwarded external calls.

Again my setup:

Trunk - CID = Blank
Outbound Route - CID = Company Number, Override Extension = No, Route Type = None Selected.
Extension Outbound CID = Blank. (unless there’s a number other than set on the outbound route)

Everything works perfect.

That’s what the Bulk Handler is for. Add/Updating/Removing en mass based on the contents of that file.

However, there is nothing wrong with your scheme either. It should work just fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.