Calls drop at 30 minutes

1800 seconds / 60 seconds = 30 minutes

Assuming I need to set this at the trunk level? Or is there a hidden setting the Adv SIP settings?

Since it is chan_sip, you add it in Asterisk SIP Settings. In the Chan SIP Settings there will be at the bottom to add “Other SIP Settings”

session-expires= 3600 (one hour, or add more for more time)

That was it! I could hear most of the people in the office cheer as the timer clicked over to 31 minutes. Thanks for all the help!

1 Like

Make want to mark it as solved so others can easily find the solution

The session expiry was previously set to 1800. At the halfway point a reINVITE is sent to renegotiate an extension to the session. This INVITE signalling fails for some reason which is why the call dropped. Extending the session expiry is not a solution so much as a band-aid, albeit one that may well work fine for you. It’s possible that other problems may emerge as a result of not resolving the original signaling failure.

1 Like

We did some further testing and I was able to sweet talk one of our vendors into looking at their logs. Additionally, the users have informed me that Verizon Wireless users don’t experience the same thing and the calls last the full duration (would have been nice to know earlier but hey…users will be users). Come to find out, the reinvite for some of these providers (US Cellular, legacy SFB/Lync, etc.) sends a morphed packet that my IPS is tossing out and then following up with an acceptable packet that the IPS allows…3 seconds later. Conveniently, the threat logs on the firewall weren’t logging to that verbosity so it went unnoticed.

I set the session expiry to 3600 and we were able to hold a 2+ hour call without a drop. Just to kill my curiosity, I set the session expiry to 1805 and still no dropping.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.