Calls are coming in but I cannot call out

The following is my logs:

[2013-05-16 10:46:20] WARNING[3192] res_phoneprov.c: Unable to load users.conf
[2013-05-16 10:46:20] VERBOSE[3192] loader.c: – Reloading module ‘res_rtp_asterisk.so’ (Asterisk RTP Stack)
[2013-05-16 10:46:20] VERBOSE[3192] config.c: == Parsing ‘/etc/asterisk/rtp.conf’: Found
[2013-05-16 10:46:20] VERBOSE[3192] config.c: == Parsing ‘/etc/asterisk/rtp_additional.conf’: Found
[2013-05-16 10:46:20] VERBOSE[3192] config.c: == Parsing ‘/etc/asterisk/rtp_custom.conf’: Found
[2013-05-16 10:46:20] VERBOSE[3192] res_rtp_asterisk.c: == RTP Allocating from port range 10000 -> 20000
[2013-05-16 10:46:20] VERBOSE[3192] loader.c: – Reloading module ‘res_xmpp.so’ (Asterisk XMPP Interface)
[2013-05-16 10:46:20] WARNING[1583] sip/config_parser.c: nat=yes is deprecated, use nat=force_rport,comedia instead
[2013-05-16 10:46:20] VERBOSE[1583] config.c: == Parsing ‘/etc/asterisk/sip_notify.conf’: Found
[2013-05-16 10:46:20] VERBOSE[1583] config.c: == Parsing ‘/etc/asterisk/sip_notify_custom.conf’: Found
[2013-05-16 10:46:20] VERBOSE[1583] config.c: == Parsing ‘/etc/asterisk/sip_notify_additional.conf’: Found
[2013-05-16 10:49:07] VERBOSE[1583][C-00000005] netsock2.c: == Using SIP RTP TOS bits 184
[2013-05-16 10:49:07] VERBOSE[1583][C-00000005] netsock2.c: == Using SIP RTP CoS mark 5
[2013-05-16 10:49:07] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:1] ResetCDR(“SIP/102-00000006”, “”) in new stack
[2013-05-16 10:49:07] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:2] NoCDR(“SIP/102-00000006”, “”) in new stack
[2013-05-16 10:49:07] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:3] Progress(“SIP/102-00000006”, “”) in new stack
[2013-05-16 10:49:07] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:4] Wait(“SIP/102-00000006”, “1”) in new stack
[2013-05-16 10:49:08] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:5] Progress(“SIP/102-00000006”, “”) in new stack
[2013-05-16 10:49:08] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:6] Playback(“SIP/102-00000006”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
[2013-05-16 10:49:08] VERBOSE[3263][C-00000005] file.c: – <SIP/102-00000006> Playing ‘silence/1.ulaw’ (language ‘en’)
[2013-05-16 10:49:09] VERBOSE[3263][C-00000005] file.c: – <SIP/102-00000006> Playing ‘cannot-complete-as-dialed.gsm’ (language ‘en’)
[2013-05-16 10:49:12] VERBOSE[3263][C-00000005] file.c: – <SIP/102-00000006> Playing ‘check-number-dial-again.gsm’ (language ‘en’)
[2013-05-16 10:49:14] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:7] Wait(“SIP/102-00000006”, “1”) in new stack
[2013-05-16 10:49:15] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:8] Congestion(“SIP/102-00000006”, “20”) in new stack
[2013-05-16 10:49:15] WARNING[3263][C-00000005] channel.c: Prodding channel ‘SIP/102-00000006’ failed
[2013-05-16 10:49:15] VERBOSE[3263][C-00000005] pbx.c: == Spawn extension (from-internal, 15088292005, 8) exited non-zero on ‘SIP/102-00000006’
[2013-05-16 10:49:15] VERBOSE[3263][C-00000005] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/102-00000006”, “”) in new stack
[2013-05-16 10:49:15] VERBOSE[3263][C-00000005] pbx.c: == Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/102-00000006’
[2013-05-16 10:49:57] NOTICE[1583] chan_sip.c: Registration from ‘Billing line sip:[email protected]’ failed for ‘216.236.255.194:34720’ - No matching peer found
[2013-05-16 10:49:57] NOTICE[1583] chan_sip.c: Registration from ‘Billing line sip:[email protected]’ failed for ‘216.236.255.194:34720’ - No matching peer found

If someone wants to look at my set up I would be happy to give them the username and password. I can also pay them by the hour.

Looks like Asterisk is not able to find out the trunk to dial out the number. Please share your Outbound Route & Trunk configuration.

Certainly looks like either your outbound routes don’t cater for the number pattern dialled or your trunk settings may be wrong. As mentioned above post your outbound routes and trunk settings.

Make sure you use the wizard when setting up outbound routes… Here is what mine looks like for my Sipstation Routes.

http://i1163.photobucket.com/albums/q556/deanot26508/dialpattern_zpsf988e587.png

Depending on how many trunks you have, you may have to put different rules in place so the cal will be routed to the correct your outbound routes. For instance, I have one of my trunks using Flowroute, it’s only use is for international calling and it has it’s own dial rule.