Callers are unable to press 0 during voicemail to get transferred to the operator

Hello very basic functionality not operational. Have a FreePBX Distro server that the inbound route is set to an IVR. The IVR has selections that ultimately get transferred to an extension that has a voicemail.

Standard practice is for the caller to be able to press 0 and be transferred to the operator. The operator extension (a ring group) has been programmed in the settings > voicemail admin > dialplan behavior > operator extension.

We are able to use the IVR without issues.

We are able to listen to voicemail by press * when the voicemail greeting is being played
With vmx-locater on or off with unavailable, busy, temp checked or unchecked the only DTMF that is responded to during that voicemail message being played is the " * " to be able to listed to the voicemail.

Any obvious things that I should check possibly for an issue such as this??

Use the asterisk cli with verbose output “asterisk -rvvv” while completing the desired action. This will help you determine if the correct DTMF tone is being matched when pressed by a caller. Or if it’s a call flow logic issue.

good luck

Thank you for the reply. I will try this and report back

Read

http://www.asteriskdocs.org/en/3rd_Edition/asterisk-book-html-chunk/Voicemail_id263499.html

you might need to define your exit context to suit as well as as enableing the operator context in the gui, check all that got set in /etc/asterisk/voicemail.conf.

@zigge I got my putty all fired up and entered the asterisk cli (asterisk -rrrrrrrrvvvvvvvv) and dialed in, received the IVR and made a selection that terminated at an extension that didn’t answer and the voicemail greeting played. While this greeting played I attempted to hit 0 to be taken back to the operator and nothing, no indications on the CLI that the system heard the DTMF tone for the 0 I was pressing.

@dicko I will be trying your recommendation next. Thanks so much for replying.

@dicko Here is my voicemail.conf file for this server

;!
;! Automatically generated configuration file
;! Filename: voicemail.conf (/etc/asterisk/voicemail.conf)
;! Generator: app_voicemail
;! Creation Date: Tue Aug 23 14:16:12 2016
;!
[general]
#include "vm_email.inc"
#include "vm_general.inc"


[default]

9612 => 9955,Jill,,,attach=no|saycid=no|envelope=no|delete=no
9610 => 9955,Reception,,,attach=no|saycid=no|envelope=no|delete=no
9611 => 9955,Office 1,,,attach=no|saycid=no|envelope=no|delete=no
9621 => 4444,Chuck,[email protected],,attach=yes|saycid=yes|envelope=yes|delete=no
9632 => 9955,Omar,[email protected],,attach=yes|saycid=yes|envelope=yes|delete=no
9633 => 9955,Rich,[email protected],,attach=yes|saycid=yes|envelope=yes|delete=no
9631 => 9955,Joe,[email protected],,attach=yes|saycid=yes|envelope=yes|delete=no

I’m not exactly sure what you are referring to when you say an “exit context” but I don’t think I have one specified here. If you would like for me to specify one please provide me code and explain how I would do that, this is an automatically generated file which means I cannot manually edit it without it be overwritten automatically.

Means that file is included at that point in the file.

Any other ideas possibly??

Hi!

Is Settings > Voicemail admin > Settings > General > Operator set to Yes?

(This seems to be, currently, the default value but maybe it wasn’t always or someone changed it…)

Good luck and have a nice day!

Nick

Hi there. Thanks for replying. That is set to “yes”. This is baffling me

Again, what is your exitcontext set to in the voicemail.conf heirarchy?

Hi there sorry about that. I misunderstood an earlier post. I thought you were saying that if I did have “vm_general.inc” that it was the exit context.

Ok so I looked in the vm_general.inc file and I don’t see anything that specifically references “exit context” so I copied the whole file and pasted below for your review.

;! Automatically generated configuration file
;! Filename: voicemail.conf (/etc/asterisk/vm_general.inc)
;! Generator: app_voicemail
;! Creation Date: Tue Aug 23 14:16:12 2016
;!
;-----------------------------------------------------------------------------------
; NOTICE:
; Any entries set in this file will override the voicemail GUI and force the GUI
; to show the value of these entries. It will prevent the GUI from making changes
; and saving them out. If you want to manage these or any other settings from the
; GUI you should remove or comment them out here.
;-----------------------------------------------------------------------------------

; 1st listed format gets emailed
;format=wav49|wav

;attach=yes
;pbxskip=yes ; Don’t put [PBX]: in the subject line
;[email protected] ; Who the e-mail notification should appear to come from
;fromstring=Voicemail System ; Real name of email sender
;maxsilence=5 ; Wait for 5 silent seconds and end the voicemail
;silencethreshold=128 ; What do we consider to be silence
;skipms=3000 ; How many miliseconds to skip forward/back when rew/ff in message playback
;review=yes ; Allow sender to review/rerecord their message before saving it
;operator=yes ; Allow caller to press 0
;nextaftercmd=yes ; Automagically play next message when current message is deleted or saved

; Asterisk pre 1.6.2 options:
;maxmessage=180 ; max length of vm message
;minmessage=3 ; Minimum length of a voicemail message in seconds

; Asterisk post 1.6.2 options the minmessage and maxmessage are deprecated in favor of these
; which are per user settable also:
;maxsecs=180 ; max length of vm message
;minsecs=3 ; Minimum length of a voicemail message in seconds

; If using Asterisk 1.6 and ARI or other sources for mail, you should set pollmailboxes to
; yes and pollfreq if you want to change the default 30 sec polling
;
pollmailboxes = yes
pollfreq = 10
; If using IMAP storage, the username and password are specified in the user/extension
; configuration, while the global settings are here
;
;imapserver=server.domain.com ; Specify the IP address or hostname of the IMAP server
;imapflags=notls ; Specify any IMAP flags needed here (“notls” for example)
;imapfolder=Inbox ; Specify the IMAP folder where voicemails and/or greetings are stored
;expungeonhangup=yes ; Mark messages for deletion on hangup
;imapgreetings=yes ; Store greetings in IMAP as well
;
;forcename=yes ; Forces a new user to record their name. A new user is
; determined by the password being the same as
; the mailbox number. The default is “no”.
;forcegreetings=yes ; This is the same as forcename, except for recording
; greetings. The default is “no”.

Two things , it is ‘exitcontext’ not ‘exit context’ and until you get what you need when you run . .

grep exitcontext /etc/asterisk/vm*

then it won’t work.

This how comedian mail will know where to go if you dial 0, otherwise as my link stared

By default, the context the caller came from will be used as the exit context. If desired, this setting will define a different context for callers exiting the voicemail system.

No results @dicko when that command given. There is none. Ok now that we have figured that out can you tell me the command to enter so the 0 will take someone to the systems operator extension. The command and where to enter it would be fantastic if it’s that easy.

I sincerely appreciate your help @dicko!! Thank you

If you use the distro, it should do that for you, if not you will have to use a text editor. You should post a log of a call that failed.

It is the disto but an older version, I cannot check right now exactly the number. But I will report tomorrow.
Yes the text editor is the easy part for me. I’m just not sure the code to enter and into what file.

it might look something like

ext-group,600,1

Hi,
I had an issue where the “press 0” option would work for some but not all extensions. What I did to fix this was go to Settings > Voicemail admin > Settings > General > Operator and shut it off, apply the change, them turn it back on and apply the changes. This corrected the non-working extensions.