CallerID lookup source does not work

I am using bronze (Asterisk 1.6) with FreePBX 2.8.1.4 and I am trying to use CallerID lookup sources with bulkcnam.com.

I got bulkCNAM configured as lookup source and enabled it in my inbound route. That’s plain vanilla FreePBX no code changes and it does not work. I don’t even see any CNAM lookup calls in the log. Anybody know how to fix this?

I don’t need superfecta that’s overkill for me. I just want to do a simple callerID lookup.

You have to provide more details.
How did you set up this cidlookup? (I guess http).
Look in your /etc/asterisk/extensions_additional.conf for the section [cidlookup] and see if the entries are there.

OK. Problem was that FreePBX bypasses the inbound route if CID and DID is blank and uses the [from-sip-external] context predefined in extensions.conf

Now my problem is that caching does not work. I defined the bulkcnam lookup with caching but FreePBX saves the context like this.

[cidlookup]
include => cidlookup-custom
exten => cidlookup_2,1,Set(CALLERID(name)=${CURL(http://cnam.bulkCNAM.com:80/index?id=xxxxxxxxxxxxxxxxxxxxxxxxx&did=${CALLERID(num)})})
exten => cidlookup_2,n,Return()
exten => cidlookup_return,1,ExecIf($["${DB(cidname/${CALLERID(num)})}" != “”]?Set(CALLERID(name)=${DB(cidname/${CALLERID(num)})}))
exten => cidlookup_return,n,Return()

instead of like this:
[cidlookup]
include => cidlookup-custom
exten => cidlookup_2,1,GotoIf($[${DB_EXISTS(cidname/${CALLERID(num)})} = 1]?cidlookup,cidlookup_return,1)
exten => cidlookup_2,n,Set(CURLOPT(httptimeout)=7)
exten => cidlookup_2,n,Set(CALLERID(name)=${CURL(http://cnam.bulkCNAM.com:80/?id=xxxxxxxxxxxxxxxxxxxxxxxxx=${CALLERID(num)})})
exten => cidlookup_2,n,Set(DB(cidname/${CALLERID(num)})=${CALLERID(name)})
exten => cidlookup_2,n,Return()
exten => cidlookup_return,1,ExecIf($["${DB(cidname/${CALLERID(num)})}" != “”]?Set(CALLERID(name)=${DB(cidname/${CALLERID(num)})}))
exten => cidlookup_return,n,Return()

What is the version of the cidlookup module? I just tested it on a 2.9 system and I can’t duplicate the issue.

2.8.0.1

That is not the latest version, please check for updates, there was an issue with caching that was resolved with 2.8.0.2. Make sure that you update all updates availabe.

Module admin says I got the latest version with 2.8.0.1

and suddenly it shows up in module admin. Problem solved. Thanks to whoever made it available.

I don’t know what you mean by “rolling it out” if the module is in the repository it has been published.

If your system is not detecting the availability of updates that is worth looking into.

The module_admin command line tool has many more options than the web GUI.

If version 2.8.0.2 exists then why does Module admin not find the update? Are you sure it’s available in FreePBX 2.8.1.4 ?

DCI, you don’t have to guess at what is the current version simply browse the repository at http://mirror.freepbx.org/modules

If you install subversion on your system you can also pull the latest updates when needed before they are even rolled.

Hey Thanks. It’s great that I can check but I wonder why the update was not released.

I see that 2.8.0.3 is already available and my system says it’s current with 2.8.0.1. How come these modules are not released? Was there a problem with 2.8.0.2 and you decided to wait for the next version before rolling it out?