CALLERID for forwarded call. How to change?

I have Trixbox installed (freePBX 2.2.2). By default - all calls forwarded out form my Trixbox (i.e. to my handy) are using CALLERID from original incomming call. The problem is that my VoIP provider will allow only outgoing calls from numbers (with sip From) which he assigned to me, others will be released.

So the question is where and how to setup CALLERID handling for outgoing calls. As the best - I want use for all forwarded calls Outbound CID set for each extension in extensions settings.

Thanks for your help!


In the Trunk setup for your provider: “Never Override CallerID” - check that box (and read the tootip for more info).

Philippe Lindheimer - FreePBX Project Lead
http// - IRC #freepbx

thank you, It is O.K now!

Sorry for my previous dumb question.


Happened to me on a Japanese system too. Seems a real problem in countries with strong PTTs.