Hello everyone,

I have been using FreePBX for quite a while and decided to put together a new PBX.

So here is the specs:

CentOS 6.2 (64)
I imported the extensions from my other PBX but one thing I noticed is that in sip-additional.conf the callerid= field changes from the name to device when I either save an existing or create a new extension.

it used to be:
callerid=Dan <309>

now its:
callerid=device <309>

I searched and played with this for a day before deciding to see if anyone has seen this.

this presents a problem as I use MonAST panel and it reads this line and now everything shows up as “device” vs the callerid name.

any thoughts?


It has been that way for quite some time and that is in fact correct if you setup your extensions in extensions mode vs. “deviceanduser” mode.

The actual CallerID is derived from the “AMPUSER” object for the user who is currently logged into the device. All this is usually pretty transparent to most people.

In 2.10, we recently made a modification such that if the device is a “fixed” device, which is always the case if created in extension mode, then when generating the sip_additional.conf file, we will in fact replace the “device” part to the CallerID with the display name of the “permanently logged in user” which is affectively what a ‘fixed’ device is. You will have to upgrade to 2.10 to get this option, though that is the mainstream stable release at this point.

Thank you very much for the info. I will update to 2.10.


I have the same problem FREEPBX 2.8.1 , Centos 5.10 Final . what is my problem …