Caller ID

FreePBX Version 2.4.0.1

A client states that their main number shows up in caller ID duplicated. I was wondering where in FreePBX would I adjust caller ID for that main number? I can mess with individual extensions, but how about an actual physical number?

What do you mean by duplicated? the number is something like 55512125551212? or it shows up on two separate lines where the number is in the regular number place and a second time for the name place?

Also where is this showing up on there own phones when a call comes in or on the receiving end of a call?

The client emailed me that. Let me ask them your questions to get a clearer picture. I was just thinking that maybe it was in an area on FreePBX where I could “see” what he was talking about.

The client states that the number shows up on two separate lines. Previously the name would be
on top and the number would be below. This occurs on incoming calls. They have Polycom 501s and 601s.

well, it all depends…

Realize that the CID name is provided by the telco they are connected to and how they look it up in the national database (maintained by all the telcos). So if the incoming caller’s telco entered the phone number as the name in the national DB you can get that (that is one possibility).

It is also possible that the setup of the phones as been messed up somehow and now it is duplicating the display info because it was instructed to.

One thing to do is have a external caller that you KNOW has good CallerID info call them, and see what happens. While that is happening also set verbose to 3 and capture the call trace info from asterisk and review it.

You should see something like this coming in
Nov 18 09:32:01 VERBOSE[13442] logger.c: – Executing NoOp(“Zap/2-1”, “user-callerid: WITS 2001 571xxxxxxx”) in new stack

and later on when the call completes and you have the CDR enabled
Nov 18 09:33:11 DEBUG[13442] cdr_addon_mysql.c: cdr_mysql: SQL command as follows: INSERT INTO cdr (calldate,clid,src,dst,dcontext,channel,dstchannel,lastapp,lastdata,duration,billsec,disposition,amaflags,accountcode,uniqueid,userfield) VALUES (‘2008-11-18 09:31:50’,’"WITS 2001 " <571xxxxxxx>’,‘571xxxxxxx’,‘439’,‘from-did-direct’, ‘Zap/2-1’,‘SIP/439-08e2ba98’,‘VoiceMail’,‘[email protected]|u’,81,81,‘ANSWERED’,3,’’,‘1227018710.18638’,’’)
with the same name inserted. So if they have it in the logs but not on the phone then something is wrong with the phone config. If the CallerID is not showing up correctly then you need to talk to the telco providing service.

I hope that helps with places to look and see what is happening.

Great response, thank you! I’ll let you know how it turns out. Again, thank you!

It looks as if the caller ID is perfect in the CDR. So it must be messed up in the phone. Do you have any idea where to look on the phone config. files? Would it even be in there?

I’m not a Polycom phone expert to tell you where to look unfortunately. Have you tried the simple approach of rebooting a phone first to see if it clears the issue up? Yea I know that is like 3 minutes of hell waiting for it to come back up…

Yeah, I tried that. I’m really starting to hate those phones. The Cisco’s are so much easier to configure.

Cisco’s are not really easy either but 90% of that is due to Cisco only wanting to support them on other Cisco stuff. If you’ve ever called them for support on a phone WITH a valid support contract and say the work asterisk, You’ll see a technical support person go from being smart to stupider then a dumb blond faster then you can imagine.

I love Aastra phones they are straight forward and simple to configure. Great for the $ and good quality to boot (Cisco is much better but cost a lot more).

Polycom’s are just a pain in the A$$ to configure quickly. to many lines to edit, to many files to download and merge to make work, and they are just REAL slow to boot. Don’ttry and do a firmware upgrade it can quadriple the boot time easy.

I did a firmware upgrade for some Polycoms last week. It was ridiculous. I was looking around the client site for some good magazines to read while waiting!

well if you updated to the latest firmware that could also be the issue… they might have introduced a bug… would not be the first time…

Since that upgrade in firmware not only is caller ID messed up, but the clocks flash on the phone. Despite putting in the correct SNTP settings it’s still not working.

Do you have a phone that is correctly displaying the CID?, and easy to program like a Grandstream or Aastra? That way you could program it up, replace the offending phone and determine if it’s a systemic or localized issue.

Bill/W5WAF

I disagree, the Polycom phones are easy to configure once you learn the setup and no other phone comes close in sound quality. The Aastras sound like tin cans by comparison.

If the firmware is the only thing that has changed AND the phone is now flashing the time. It is a safe bet that you have a mangled config file. What version of the firmware are you currently using and where did you get it from? (Some distros mutilate the cfg files). How did you upgrade?

I didn’t perform the upgrade. It was another technician. Let me find out how he did it, and go from there. Hey, have you ever had any issues with the sidecars? On some phones I get the sidecar to come up without a problem. On other phones they don’t light up at all. Could that be a firmware issue as well?