Caller ID Superfecta Config for Asteridex

I have a Trixbox system running the latest freepbx and I installed the “Caller ID Superfecta” as well as Asteridex. I wet through the configuration and set the incoming route to use SF, which the logs seem to show, but it cant connect to the asteridex db which runs on a different machine. The admin gui for Asteridex runs fine so the db connections are correct, but I guess this needs to be set somewhere in Caller ID Superfect so it knows how to connect to asteridex? Where do I set the db parameters for Superfecta so it can find asteridex?

Thanks to anyone that can help. Below is an incoming call log showing the failure to connect to asteridex.

[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:2] Gosub(“Zap/4-1”, “cidlookup|cidlookup_1|1”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:1] Set(“Zap/4-1”, “CALLERID(name)=AsteriDex connection failed”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:2] Return(“Zap/4-1”, “”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:3] Gosub(“Zap/4-1”, “app-blacklist-check|s|1”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:1] LookupBlacklist(“Zap/4-1”, “”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:2] GotoIf(“Zap/4-1”, “0?blacklisted”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:3] Return(“Zap/4-1”, “”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:4] ExecIf(“Zap/4-1”, “0 |Set|CALLERID(name)=6048481125”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:5] Set(“Zap/4-1”, "[email protected]") in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:6] Answer(“Zap/4-1”, “”) in new stack
[May 5 19:37:30] DEBUG[25367] chan_zap.c: Took Zap/4-1 off hook
[May 5 19:37:30] DEBUG[25367] chan_zap.c: No echo training requested
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:7] Wait(“Zap/4-1”, “0”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:8] Set(“Zap/4-1”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:9] SetCallerPres(“Zap/4-1”, “allowed_not_screened”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:10] Goto(“Zap/4-1”, “timeconditions|1|1”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Goto (timeconditions,1,1)
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:1] GotoIfTime(“Zap/4-1”, “08:00-19:00|mon-sun||?ext-group|600|1”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:2] Goto(“Zap/4-1”, “ivr-2|s|1”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Goto (ivr-2,s,1)
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:1] Set(“Zap/4-1”, “MSG=custom/Bonny-Standard”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:2] Set(“Zap/4-1”, “LOOPCOUNT=0”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:3] Set(“Zap/4-1”, “__DIR-CONTEXT=default”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:4] Set(“Zap/4-1”, “_IVR_CONTEXT_ivr-2=”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:5] Set(“Zap/4-1”, “_IVR_CONTEXT=ivr-2”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:6] GotoIf(“Zap/4-1”, “1?begin”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Goto (ivr-2,s,9)
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:9] Set(“Zap/4-1”, “TIMEOUT(digit)=3”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Digit timeout set to 3
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:10] Set(“Zap/4-1”, “TIMEOUT(response)=10”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Response timeout set to 10
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:11] Set(“Zap/4-1”, “__IVR_RETVM=”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – Executing [[email protected]:12] ExecIf(“Zap/4-1”, “1|Background|custom/Bonny-Standard”) in new stack
[May 5 19:37:30] VERBOSE[25367] logger.c: – <Zap/4-1> Playing ‘custom/Bonny-Standard’ (language ‘en’)
[May 5 19:37:53] VERBOSE[25367] logger.c: – Executing [[email protected]:13] WaitExten(“Zap/4-1”, “|”) in new stack

Are you using a module version? If so, which one?

The newer versions of the Asteridex data- source support user configurable options - specifically to support situations like this. Its exactly what you need.