Caller ID Issue

I am having an issue with my caller ID passing a + in addition to the area code and number.

I am using for incoming calls and Plivo’s Zentrunk to send calls.

We use call queues for inbound calls. While these calls are parked in the call queue, the extension for each of the agents in the queue is called. The extension automatically forwards the call to their cell phone.

When the call comes in to the agents cell phone it only displays the area code and number, not the country code. This makes the phone think the call is not local and shows on the caller id that it is from other countries. Additionally, the system prefixes a + before the area code. The country code is missing.

The phones are Android. The caller ID shows properly in the call logs until it leaves the PBX on the outbound call.

I have tried changing the dialed number manipulation rules with no success.

These are the only SIP settings I am using as per Plivo’s help files (located here:

In the Dial Number Manipulation Rules I only have one line and only a “.” is placed in the match pattern line.

In the CDR report it shows the dialed number being only the area code and number. No + or 1.

In the Plivo server logs it shows on the area code and number. No + or 1.

I have to be missing something and have been pulling my hair out on this one. Any suggestions?