Caller doesn't hear rings or person called when Fax detection is turned off for inbound route

This one is a strange one, be warned.
I have inbound route, based on DID. The route sends the caller directly to an extension (private phone number for each user).
When the caller calls, they have dead silence. The physical phone rings, and the answering party hears the caller.
Now, If I turn on Fax detection on the route, everything works wonderfully.
Voip carrier is Broadvoice.
Freepbx is at latest version (FreePBX with latest modules updated and latest asterisk ( Asterisk Version: 13.14.0)
This behavior has been experienced since installation 2 weeks ago. Original installation was 10.13.66-64 bit running asterisk 13.12 initially. We upgraded asterisk and freepbx in hopes that it would fix this, it made no difference to this behavior.

Has anyone else seen this behavior and found a fix/solution? I have officially run out of ideas.
And before anyone asks, I have checked and double checked the NAT settings to be sure the outside and inside network settings were right.

Set canreinvite = no on the trunk ?


Yeah, this isn’t as wierd as you think. We just had a guy using PJ-SIP run into essentially the same problem. Since we know that FAX Detect fixes the problem in both PJ-SIP and Chan-SIP, I recommend you just let FAX detection solve the problem.

Note that there is something in the early part of the call that is causing this problem - I have no idea what, but using FAX detection to solve it is low-cost and tested.

If you want to submit a ticket on it and are willing to help the developers out with debug output (at their request, of course), there might be something that they can do that works better than turning on FAX detection.

Thanks all for your replies. Turns out it was Nat just not where I expected it to be… My firewall was configured to only pass certain ports through NAT conversion, and it seems that our carrier uses more ports than i was expecting. Once I modified my NAT to go strictly on IP addresses, ignoring ports everything worked perfectly.
If anyone has this issue using a new version Sonicwall firewall, I will be happy to help them solve it.

i still have no idea why adding fax detection let it work, but since it is working as designed now, I will stop digging.

Fax detection requires answer() so perhaps add that to your inbound macro , or use chan-sip for your trunks, (which will probably work as expected as it has for years)


We have found the culprit and fixed it. Was a firewall issue.